summaryrefslogtreecommitdiff
path: root/x11-misc/xwallpaper
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-27 22:40:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-03-27 22:40:05 +0100
commit8c364c784966be1700ea39ae45028f3e9be9cae0 (patch)
treec1971211069b79e3831b71accd52a67a9fdc77a3 /x11-misc/xwallpaper
parent6bd95d1f6320b8666a31ec949183aaa3088aa16f (diff)
gentoo resync : 27.03.2018
Diffstat (limited to 'x11-misc/xwallpaper')
-rw-r--r--x11-misc/xwallpaper/Manifest4
-rw-r--r--x11-misc/xwallpaper/metadata.xml22
-rw-r--r--x11-misc/xwallpaper/xwallpaper-0.3.0.ebuild48
-rw-r--r--x11-misc/xwallpaper/xwallpaper-9999.ebuild48
4 files changed, 122 insertions, 0 deletions
diff --git a/x11-misc/xwallpaper/Manifest b/x11-misc/xwallpaper/Manifest
new file mode 100644
index 000000000000..634be2810278
--- /dev/null
+++ b/x11-misc/xwallpaper/Manifest
@@ -0,0 +1,4 @@
+DIST xwallpaper-0.3.0.tar.gz 104300 BLAKE2B 23ec3b4ccbaf910c9ba4afbd1d9237223654a85c90b0a147141b017a9b3917316f745e1dd70a89e385110d380d5bbba8ee7c2d1ed4188d87a98ba0e94c5a7b6c SHA512 c73583fdbd573329951178d7db36fb1ae18a4294207de85dfb93e367be0ed103e8de7e2dd8ec61a0a23541457c930e8b0e5eb12dd5024808de3e02ddefb6b4a3
+EBUILD xwallpaper-0.3.0.ebuild 989 BLAKE2B 99fb573839f4990f7a3ab6b0ece3e87f8389b66e4dac4a303fb5372d143c008b808fc06a0ca43636d612d6c976717cea5d7f8cd711136476a837bf7f3a26fbec SHA512 b338de596750da56107cf760420451b129ead2bd233b593012e921fd86bd5b19554b74e1304442a038c79a1542ad64a2e9016d9212f30a5d783020b95204da19
+EBUILD xwallpaper-9999.ebuild 989 BLAKE2B 99fb573839f4990f7a3ab6b0ece3e87f8389b66e4dac4a303fb5372d143c008b808fc06a0ca43636d612d6c976717cea5d7f8cd711136476a837bf7f3a26fbec SHA512 b338de596750da56107cf760420451b129ead2bd233b593012e921fd86bd5b19554b74e1304442a038c79a1542ad64a2e9016d9212f30a5d783020b95204da19
+MISC metadata.xml 915 BLAKE2B 8849ddadb92292a654650b0e4febcc3eb2dbd5137d38b2ef15fa6ac1726b014432908da049c8af6639477fa0697f604ce81b954653048c3a9e9e79c95c208f46 SHA512 9a6fab09b2e9dabc97b8bf4454ab70cb3a235570f01af16807c9420b6ed60d96ee63c4be186a2507b6773bcc9bf7e69718eee75391c46c4e127b26bcc344e537
diff --git a/x11-misc/xwallpaper/metadata.xml b/x11-misc/xwallpaper/metadata.xml
new file mode 100644
index 000000000000..36a2d7518765
--- /dev/null
+++ b/x11-misc/xwallpaper/metadata.xml
@@ -0,0 +1,22 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>ya@sysdump.net</email>
+ <name>Georgy Yakovlev</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ The xwallpaper utility allows you to set image files as your X wallpaper.
+ JPEG, PNG, and XPM file formats are supported, all of them being configurable and therefore no fixed dependencies.
+ The wallpaper is also advertised to programs which support semi-transparent backgrounds.
+ The last but not least focus of this project is to write a secure wallpaper utility,
+ supporting very tight sandboxing mechanisms.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">stoeckmann/xwallpaper</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-misc/xwallpaper/xwallpaper-0.3.0.ebuild b/x11-misc/xwallpaper/xwallpaper-0.3.0.ebuild
new file mode 100644
index 000000000000..45080788129f
--- /dev/null
+++ b/x11-misc/xwallpaper/xwallpaper-0.3.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Wallpaper setting utility for X"
+HOMEPAGE="https://github.com/stoeckmann/xwallpaper"
+
+if [ ${PV} == "9999" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/stoeckmann/${PN}.git"
+else
+ SRC_URI="https://github.com/stoeckmann/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="jpeg png seccomp xpm"
+
+DEPEND="
+ x11-libs/pixman
+ x11-libs/xcb-util
+ x11-libs/xcb-util-image
+ jpeg? ( virtual/jpeg:0= )
+ png? ( media-libs/libpng:0= )
+ seccomp? ( >=sys-libs/libseccomp-2.3.1:0= )
+ xpm? ( x11-libs/libXpm )"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+src_configure() {
+ local myconf=(
+ $(use_with jpeg)
+ $(use_with png)
+ $(use_with seccomp)
+ $(use_with xpm)
+ --with-randr
+ --with-zshcompletiondir="${EPREFIX}/usr/share/zsh/site-functions"
+ )
+ econf "${myconf[@]}"
+}
diff --git a/x11-misc/xwallpaper/xwallpaper-9999.ebuild b/x11-misc/xwallpaper/xwallpaper-9999.ebuild
new file mode 100644
index 000000000000..45080788129f
--- /dev/null
+++ b/x11-misc/xwallpaper/xwallpaper-9999.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Wallpaper setting utility for X"
+HOMEPAGE="https://github.com/stoeckmann/xwallpaper"
+
+if [ ${PV} == "9999" ] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/stoeckmann/${PN}.git"
+else
+ SRC_URI="https://github.com/stoeckmann/${PN}/releases/download/v${PV}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="jpeg png seccomp xpm"
+
+DEPEND="
+ x11-libs/pixman
+ x11-libs/xcb-util
+ x11-libs/xcb-util-image
+ jpeg? ( virtual/jpeg:0= )
+ png? ( media-libs/libpng:0= )
+ seccomp? ( >=sys-libs/libseccomp-2.3.1:0= )
+ xpm? ( x11-libs/libXpm )"
+
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+src_configure() {
+ local myconf=(
+ $(use_with jpeg)
+ $(use_with png)
+ $(use_with seccomp)
+ $(use_with xpm)
+ --with-randr
+ --with-zshcompletiondir="${EPREFIX}/usr/share/zsh/site-functions"
+ )
+ econf "${myconf[@]}"
+}