summaryrefslogtreecommitdiff
path: root/x11-misc/xsnap
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /x11-misc/xsnap
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'x11-misc/xsnap')
-rw-r--r--x11-misc/xsnap/Manifest1
-rw-r--r--x11-misc/xsnap/xsnap-1.5.15-r2.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/x11-misc/xsnap/Manifest b/x11-misc/xsnap/Manifest
index 1eb8a31b7599..2676c9718283 100644
--- a/x11-misc/xsnap/Manifest
+++ b/x11-misc/xsnap/Manifest
@@ -1,4 +1,5 @@
AUX xsnap-1.5.15-root_name.patch 228 BLAKE2B 5a05da8ed5f708811a1792162bbc2dc1ea01a3666391c861296fb05706d3d1a4998764d3cd98c2847cd36573f0841966d0c16bb6fb22531055ec01fcc3d49354 SHA512 965a26474cdbe809a26559ac431aa9acdbc20ff5469e58f8b95b9da0eb58e278040f233bdc42fd54aea6f556fa2a801f6f0ca610a2ed4caa100172cb9ead4ed1
DIST xsnap-1.5.15.tar.bz2 46574 BLAKE2B 4d0f67adea6f456bd92031752a307293d736b9ce14aa35435359ed7bdb9d774827130e95f526f363bc7f0bb3c8e3e637c3e4abdf7f9c157f15f7559bae3eba99 SHA512 898914dd0bfec93b641815cc07522d4ea6168266a7f5efe75715cf68555e8959a72b40b0a02e75244348afc6aa77d267fbe7ee60670da5f33e6db2f6c4476dac
EBUILD xsnap-1.5.15-r1.ebuild 1331 BLAKE2B c56655e4177ab76e08cd59d11b7e20625a9f980e5282d1d2934e7566e488afeb6a8050a270415d955e55cab4f8184cd276fe128ce912aaf1c91041807fe430c1 SHA512 b7030789a07943202a3e376b1b2b3fe4aca968b54c3c13dcee98334186b693dd18c229eaef49ee35fb4b8086050f25dbb73560be9b4074863d2344a67f20c48b
+EBUILD xsnap-1.5.15-r2.ebuild 1413 BLAKE2B 24d77de7831af6df8031e56abc05a8390466e01af4afda57ee59c2f034fb3afbd7681152ef6f9eb4fb425a6df202a886762dcc489cd4f905601e5246461a1857 SHA512 2a1d54b7a350377cbe5a278a257d4098ca5edb7c6bb5af2f7d889ecbc07101ee16075d44f2ed5ff6976867cb11b37d8da186c9709e16da56b85bce8a15d021ef
MISC metadata.xml 282 BLAKE2B f175ac89f79f8ebbe3bc806c0c4a8169e2a4b88708d85928db9a23dacecd92a2acb1c5d1f6a49a2f8375288aa4b2db910af8c325557540ba665c37a17e773721 SHA512 06c94ffb49c985c4344b170b902427ca9ce0c23b6d68330af227ab1771794f8e8b6d0ef75b5f69293c8ef0d3264c8799e1389ccdf8dfbe7c665c6477c07479e4
diff --git a/x11-misc/xsnap/xsnap-1.5.15-r2.ebuild b/x11-misc/xsnap/xsnap-1.5.15-r2.ebuild
new file mode 100644
index 000000000000..920e4a2ffcc9
--- /dev/null
+++ b/x11-misc/xsnap/xsnap-1.5.15-r2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="Program to interactively take a 'snapshot' of a region of the screen"
+HOMEPAGE="ftp://ftp.ac-grenoble.fr/ge/Xutils/"
+SRC_URI="ftp://ftp.ac-grenoble.fr/ge/Xutils/${P}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux"
+IUSE=""
+
+COMMON_DEPEND="
+ media-libs/libpng:0
+ virtual/jpeg:0
+ x11-libs/libX11
+ x11-libs/libXft
+ x11-libs/libXpm
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ media-fonts/font-misc-misc
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ app-text/rman
+ dev-lang/perl
+ x11-base/xorg-proto
+ x11-misc/imake
+"
+DOCS=( AUTHORS Changelog README )
+PATCHES=( "${FILESDIR}"/${P}-root_name.patch )
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e 's|/usr/share/locale|$(LOCALEDIR)|g' \
+ -e 's|/usr/share/man/man1|$(MANDIR)|g' \
+ -e '/cd po.*install/s|cd.*|$(MAKE) -C po LOCALEDIR=$(LOCALEDIR) install|' \
+ -e '21s|.*|LOCALEDIR = /usr/share/locale|' \
+ Imakefile || die
+ sed -i \
+ -e '/^LOCALEDIR=/d' \
+ po/Makefile || die
+
+ xmkmf || die
+
+ sed -i \
+ -e '/ CC = /d' \
+ -e '/ LD = /d' \
+ -e '/ CDEBUGFLAGS = /d' \
+ -e '/ CCOPTIONS = /d' \
+ -e 's|CPP = cpp|CPP = $(CC)|g' \
+ Makefile || die
+}
+
+src_compile() {
+ tc-export CC
+ emake CCOPTIONS="${CFLAGS}" EXTRA_LDOPTIONS="${LDFLAGS}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.1.gz' -exec gunzip {} \; || die
+}