summaryrefslogtreecommitdiff
path: root/x11-misc/xsensors/xsensors-0.70-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/xsensors/xsensors-0.70-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/xsensors/xsensors-0.70-r1.ebuild')
-rw-r--r--x11-misc/xsensors/xsensors-0.70-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-misc/xsensors/xsensors-0.70-r1.ebuild b/x11-misc/xsensors/xsensors-0.70-r1.ebuild
new file mode 100644
index 000000000000..344c180cf8e6
--- /dev/null
+++ b/x11-misc/xsensors/xsensors-0.70-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="A hardware health information viewer, interface to lm-sensors"
+HOMEPAGE="http://www.linuxhardware.org/xsensors/"
+SRC_URI="http://www.linuxhardware.org/xsensors/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ >=sys-apps/lm_sensors-3"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-gtk220.patch )
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e '/-DG.*_DISABLE_DEPRECATED/d' \
+ -e 's:-Werror:-Wall:' \
+ src/Makefile.am configure.in || die
+
+ mv configure.{in,ac} || die #426262
+
+ eautoreconf
+}