summaryrefslogtreecommitdiff
path: root/x11-misc/xrootconsole/xrootconsole-0.6-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/xrootconsole/xrootconsole-0.6-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/xrootconsole/xrootconsole-0.6-r1.ebuild')
-rw-r--r--x11-misc/xrootconsole/xrootconsole-0.6-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-misc/xrootconsole/xrootconsole-0.6-r1.ebuild b/x11-misc/xrootconsole/xrootconsole-0.6-r1.ebuild
new file mode 100644
index 000000000000..111832c3752d
--- /dev/null
+++ b/x11-misc/xrootconsole/xrootconsole-0.6-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A utility that displays its input in a text box on your root window"
+HOMEPAGE="https://sourceforge.net/projects/xrootconsole/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+
+RDEPEND="
+ x11-libs/libX11"
+
+DEPEND="
+ ${RDEPEND}
+ x11-proto/xproto"
+
+PATCHES=(
+ "${FILESDIR}/${P}.noversion.patch"
+ "${FILESDIR}/${P}.makefile.patch"
+ "${FILESDIR}/${P}.manpage.patch"
+)
+
+DOCS=( TODO NEWS CREDITS )
+
+src_compile() {
+ tc-export CC
+ emake
+}
+
+src_install() {
+ dodir /usr/bin
+
+ emake \
+ MANDIR="${D}usr/share/man/man1" \
+ BINDIR="${D}usr/bin/" \
+ install
+
+ einstalldocs
+}