summaryrefslogtreecommitdiff
path: root/x11-misc/xprintidle/xprintidle-2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/xprintidle/xprintidle-2.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/xprintidle/xprintidle-2.0.ebuild')
-rw-r--r--x11-misc/xprintidle/xprintidle-2.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/x11-misc/xprintidle/xprintidle-2.0.ebuild b/x11-misc/xprintidle/xprintidle-2.0.ebuild
new file mode 100644
index 000000000000..83b621d16fed
--- /dev/null
+++ b/x11-misc/xprintidle/xprintidle-2.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Prints user's X server idle time in milliseconds"
+HOMEPAGE="https://github.com/lucianposton/xprintidle"
+SRC_URI="https://github.com/lucianposton/xprintidle/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXScrnSaver
+ "
+RDEPEND="${DEPEND}"
+
+DOCS=(
+ AUTHORS
+ ChangeLog
+ NEWS
+ README
+)
+
+src_prepare() {
+ eapply_user
+
+ # Address "configure: WARNING: 'missing' script is too old or missing"
+ eautoreconf
+}