summaryrefslogtreecommitdiff
path: root/x11-misc/xosview/xosview-1.20-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-11-10 00:43:02 +0000
committerV3n3RiX <venerix@redcorelinux.org>2017-11-10 00:43:02 +0000
commita5332b59346f7cbf0fdbd148b54aa8a84aaf8190 (patch)
treee6d8d3589fcd01fbc3f1286185639163daa81424 /x11-misc/xosview/xosview-1.20-r1.ebuild
parentfceeaf01a28ee71065cf3798b70b77d3bc4ef199 (diff)
gentoo resync : 10.11.2017
Diffstat (limited to 'x11-misc/xosview/xosview-1.20-r1.ebuild')
-rw-r--r--x11-misc/xosview/xosview-1.20-r1.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/x11-misc/xosview/xosview-1.20-r1.ebuild b/x11-misc/xosview/xosview-1.20-r1.ebuild
new file mode 100644
index 000000000000..f342c4311c82
--- /dev/null
+++ b/x11-misc/xosview/xosview-1.20-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs xdg-utils
+
+DESCRIPTION="X11 operating system viewer"
+HOMEPAGE="http://www.pogo.org.uk/~mark/xosview/"
+SRC_URI="http://www.pogo.org.uk/~mark/${PN}/releases/${P}.tar.gz"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="suid"
+
+COMMON_DEPS="x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXt"
+RDEPEND="${COMMON_DEPS}
+ media-fonts/font-misc-misc"
+DEPEND="${COMMON_DEPS}
+ x11-proto/xproto"
+
+DOCS=( CHANGES README.linux TODO )
+
+src_prepare() {
+ default
+
+ sed -i -e 's:lib/X11/app:share/X11/app:g' -i ${PN}.1 || die
+ sed -i -e "s:Git:${PV}:g" ${PN}.cc || die
+ tc-export CXX
+}
+
+src_compile() {
+ emake OPTFLAGS=''
+}
+
+src_install() {
+ emake PREFIX="${D%/}/usr" install
+ use suid && fperms 4755 /usr/bin/${PN}
+ insinto /usr/share/X11/app-defaults
+ newins Xdefaults XOsview
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+
+ if ! use suid ; then
+ ewarn "If you want to use serial meters ${PN} needs to be executed as root."
+ ewarn "Please see ${EPREFIX}/usr/share/doc/${PF}/README.linux for details."
+ fi
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}