summaryrefslogtreecommitdiff
path: root/x11-misc/xnee/xnee-3.19-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /x11-misc/xnee/xnee-3.19-r1.ebuild
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'x11-misc/xnee/xnee-3.19-r1.ebuild')
-rw-r--r--x11-misc/xnee/xnee-3.19-r1.ebuild19
1 files changed, 12 insertions, 7 deletions
diff --git a/x11-misc/xnee/xnee-3.19-r1.ebuild b/x11-misc/xnee/xnee-3.19-r1.ebuild
index 9e2f128b15f3..0d71add730d5 100644
--- a/x11-misc/xnee/xnee-3.19-r1.ebuild
+++ b/x11-misc/xnee/xnee-3.19-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit autotools eutils
+EAPI=7
+inherit autotools desktop flag-o-matic
DESCRIPTION="Program suite to record, replay and distribute user actions"
-HOMEPAGE="http://www.sandklef.com/xnee/"
+HOMEPAGE="https://xnee.wordpress.com/"
SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
LICENSE="GPL-3"
@@ -27,7 +27,8 @@ RDEPEND="
>=gnome-base/gconf-2
)
"
-DEPEND="${RDEPEND}
+DEPEND="
+ ${RDEPEND}
x11-base/xorg-proto
virtual/pkgconfig
sys-devel/gettext
@@ -37,13 +38,17 @@ DEPEND="${RDEPEND}
# This needs RECORD extension from X.org server which isn't necessarily
# enabled. Xlib: extension "RECORD" missing on display ":0.0".
RESTRICT="test"
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.18-linker.patch
+)
src_prepare() {
- epatch "${FILESDIR}"/${PN}-3.18-linker.patch
+ default
eautoreconf
}
src_configure() {
+ append-cflags -fcommon
econf \
$(use_enable gnome gui) \
$(use_enable static-libs static) \
@@ -64,5 +69,5 @@ src_install() {
default
dodoc AUTHORS BUGS ChangeLog FAQ NEWS README TODO
use gnome && make_desktop_entry gnee Gnee ${PN} "Utility;GTK"
- use static-libs || rm -f "${ED}"usr/lib*/lib*.la
+ find "${ED}" -name '*.la' -delete || die
}