summaryrefslogtreecommitdiff
path: root/x11-misc/xmonad-log-applet
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /x11-misc/xmonad-log-applet
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'x11-misc/xmonad-log-applet')
-rw-r--r--x11-misc/xmonad-log-applet/Manifest4
-rw-r--r--x11-misc/xmonad-log-applet/files/xmonad.hs60
-rw-r--r--x11-misc/xmonad-log-applet/metadata.xml16
-rw-r--r--x11-misc/xmonad-log-applet/xmonad-log-applet-2.0.0-r301.ebuild47
4 files changed, 0 insertions, 127 deletions
diff --git a/x11-misc/xmonad-log-applet/Manifest b/x11-misc/xmonad-log-applet/Manifest
deleted file mode 100644
index 67333cd48778..000000000000
--- a/x11-misc/xmonad-log-applet/Manifest
+++ /dev/null
@@ -1,4 +0,0 @@
-AUX xmonad.hs 1801 BLAKE2B e8235819cbd5086141def1d45652750129c8153e65c52b9e72ee9b42d3dd6110e9d1b6e3da651ff18beb9b3c61e3afaa83fff9059a7d2113a0a445d2e07e0b99 SHA512 3d20f037dabff24c69811672850734396a4c4f57a9e33e03a15f93d8e5b4edcf43dadf9d95ab82c310dbf0064e8fb7a6a0e8e330c5b51997e0dffe719dd0cb21
-DIST xmonad-log-applet-2.0.0.tar.gz 82881 BLAKE2B a059158558cc2fcb150e90cbd055cf50367dbed464c46891b6c63d49d2b5e2974ea3fc859afe8f1115af78fae60e639bde0aec37af8be693720eca80905712b8 SHA512 1885ac97569d909ab1c6af99d9b271d0f782de905dfe035df27524f428d09cefa20a468103477132656dea8945faf886270fd70a49e5a08be538e04f3f05baca
-EBUILD xmonad-log-applet-2.0.0-r301.ebuild 929 BLAKE2B 6002ba6efb52cd4fc216421d146b2ffd62beae91287fc010db976e53b73f4e60692fe0387137dac3ee37b73b3c1055dffdcc43126dd5a26ef8fe124f0e836f7f SHA512 77d4c9c8c82761f62de6c382af27211842c06780e5b28f63dad436c2f94afa3d62b2ff11ab06efa9f7c9e2f2c8976dccf08fd96b1db9e6460b2033de155ec3de
-MISC metadata.xml 647 BLAKE2B 0af322628cb650feee33ab99817bdd2955689b9cfa2c4bd736d9363b1de33be9913972884792d98cfd827cbb5133e5c52ae92e747df80ba6636be8ad64f12226 SHA512 92739437a732ad395f4af992972cd4be68abb931a26e1b47e0035b0e681fa5095e5019b4f0fda178f53197fd42cdbd679b6673727fc5ac425437768f8ad12fff
diff --git a/x11-misc/xmonad-log-applet/files/xmonad.hs b/x11-misc/xmonad-log-applet/files/xmonad.hs
deleted file mode 100644
index 54b0025a97c4..000000000000
--- a/x11-misc/xmonad-log-applet/files/xmonad.hs
+++ /dev/null
@@ -1,60 +0,0 @@
-import XMonad
-import XMonad.Config.Gnome
-import XMonad.Hooks.DynamicLog
-
-import Control.OldException
-
-import DBus
-import DBus.Connection
-import DBus.Message
-
-main :: IO ()
-main = withConnection Session $ \dbus -> do
- getWellKnownName dbus
- xmonad $ gnomeConfig
- { logHook = dynamicLogWithPP (prettyPrinter dbus)
- }
-
-prettyPrinter :: Connection -> PP
-prettyPrinter dbus = defaultPP
- { ppOutput = dbusOutput dbus
- , ppTitle = pangoSanitize
- , ppCurrent = pangoColor "green" . wrap "[" "]" . pangoSanitize
- , ppVisible = pangoColor "yellow" . wrap "(" ")" . pangoSanitize
- , ppHidden = const ""
- , ppUrgent = pangoColor "red"
- , ppLayout = const ""
- , ppSep = " "
- }
-
-getWellKnownName :: Connection -> IO ()
-getWellKnownName dbus = tryGetName `catchDyn` (\(DBus.Error _ _) -> getWellKnownName dbus)
- where
- tryGetName = do
- namereq <- newMethodCall serviceDBus pathDBus interfaceDBus "RequestName"
- addArgs namereq [String "org.xmonad.Log", Word32 5]
- sendWithReplyAndBlock dbus namereq 0
- return ()
-
-dbusOutput :: Connection -> String -> IO ()
-dbusOutput dbus str = do
- msg <- newSignal "/org/xmonad/Log" "org.xmonad.Log" "Update"
- addArgs msg [String ("<b>" ++ str ++ "</b>")]
- -- If the send fails, ignore it.
- send dbus msg 0 `catchDyn` (\(DBus.Error _ _) -> return 0)
- return ()
-
-pangoColor :: String -> String -> String
-pangoColor fg = wrap left right
- where
- left = "<span foreground=\"" ++ fg ++ "\">"
- right = "</span>"
-
-pangoSanitize :: String -> String
-pangoSanitize = foldr sanitize ""
- where
- sanitize '>' xs = "&gt;" ++ xs
- sanitize '<' xs = "&lt;" ++ xs
- sanitize '\"' xs = "&quot;" ++ xs
- sanitize '&' xs = "&amp;" ++ xs
- sanitize x xs = x:xs
diff --git a/x11-misc/xmonad-log-applet/metadata.xml b/x11-misc/xmonad-log-applet/metadata.xml
deleted file mode 100644
index e8a655590796..000000000000
--- a/x11-misc/xmonad-log-applet/metadata.xml
+++ /dev/null
@@ -1,16 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>haskell@gentoo.org</email>
- </maintainer>
- <maintainer type="person">
- <email>flo@geekplace.eu</email>
- </maintainer>
- <longdescription>
- xmonad-log-applet is for Xmonad users who find the GNOME, MATE, or Xfce panel useful. The applet will show the active workspaces, the title of the selected window or whatever information you send it from your xmonad.hs.
- </longdescription>
- <upstream>
- <remote-id type="github">alexkay/xmonad-log-applet</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/x11-misc/xmonad-log-applet/xmonad-log-applet-2.0.0-r301.ebuild b/x11-misc/xmonad-log-applet/xmonad-log-applet-2.0.0-r301.ebuild
deleted file mode 100644
index 9038beb0ce04..000000000000
--- a/x11-misc/xmonad-log-applet/xmonad-log-applet-2.0.0-r301.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-inherit autotools gnome2
-
-DESCRIPTION="Gnome and XFCE applet for displaying XMonad log"
-HOMEPAGE="https://github.com/alexkay/xmonad-log-applet"
-SRC_URI="https://github.com/downloads/alexkay/${PN}/${P}.tar.gz"
-LICENSE="BSD"
-
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RESTRICT="mirror"
-
-RDEPEND="
- sys-apps/dbus
- xfce-base/xfce4-panel
- dev-libs/dbus-glib
- dev-libs/glib:2
- dev-haskell/dbus
- x11-libs/gtk+:3
-"
-DEPEND="${RDEPEND}"
-
-src_prepare() {
- eautoreconf
- gnome2_src_prepare
-}
-
-src_configure() {
- gnome2_src_configure --sysconfdir=/etc --with-panel=xfce4
-}
-
-src_install() {
- gnome2_src_install
- dodoc AUTHORS.md README.md
- dodoc "${FILESDIR}"/xmonad.hs
-}
-
-pkg_postinst() {
- gnome2_pkg_postinst
- elog "Remember to update your xmonad.hs accordingly"
- elog "a sample xmonad.hs is provided in /usr/share/doc/${PF}"
-}