summaryrefslogtreecommitdiff
path: root/x11-misc/xgestures/xgestures-0.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-16 17:51:01 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-16 17:51:01 +0100
commitd83532aee7e94505bf23da29e6224ca164aac759 (patch)
treefcd6dbea91816dd541b6c602b5fed02ca574a5f6 /x11-misc/xgestures/xgestures-0.4-r1.ebuild
parenta2844b413d00a2859401e017a0311986151e1594 (diff)
gentoo auto-resync : 16:04:2023 - 17:51:01
Diffstat (limited to 'x11-misc/xgestures/xgestures-0.4-r1.ebuild')
-rw-r--r--x11-misc/xgestures/xgestures-0.4-r1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-misc/xgestures/xgestures-0.4-r1.ebuild b/x11-misc/xgestures/xgestures-0.4-r1.ebuild
new file mode 100644
index 000000000000..e54e731d60d2
--- /dev/null
+++ b/x11-misc/xgestures/xgestures-0.4-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="A mouse gesture recognition program for X11 desktops"
+HOMEPAGE="http://www.cs.bgu.ac.il/~tzachar/xgestures.html"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ x11-libs/libXmu
+ x11-libs/libX11
+ x11-libs/libXrender
+ x11-libs/libXtst
+ x11-libs/libXt"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ default
+ newdoc .gestures gestures
+}
+
+pkg_postinst() {
+ elog "Unpack /usr/share/doc/${PF}/gestures* and copy it to \$HOME/.gestures"
+}