summaryrefslogtreecommitdiff
path: root/x11-misc/xfractint/xfractint-20.04_p12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/xfractint/xfractint-20.04_p12.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/xfractint/xfractint-20.04_p12.ebuild')
-rw-r--r--x11-misc/xfractint/xfractint-20.04_p12.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-misc/xfractint/xfractint-20.04_p12.ebuild b/x11-misc/xfractint/xfractint-20.04_p12.ebuild
new file mode 100644
index 000000000000..ba46f9dec381
--- /dev/null
+++ b/x11-misc/xfractint/xfractint-20.04_p12.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit eutils toolchain-funcs
+
+MY_P=${P/_}
+
+DESCRIPTION="A fractal generator"
+HOMEPAGE="http://www.fractint.org"
+SRC_URI="http://www.fractint.org/ftp/current/linux/${MY_P}.tar.gz"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="amd64 ppc x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11"
+DEPEND="${RDEPEND}
+ x11-libs/libXft"
+# x86? ( dev-lang/nasm )"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}/xfractint-20.04p09-ldflags.patch"
+}
+
+src_compile() {
+ # Untested, any x86 archteam dev. is allowed to uncomment this.
+ local myasm="foo"
+# use x86 && myasm="/usr/bin/nasm"
+ emake CC="$(tc-getCC)" AS="${myasm}" OPT="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}/usr" STRIP="true" install
+ newenvd "${FILESDIR}"/xfractint.envd 60xfractint
+}
+
+pkg_postinst() {
+ elog "XFractInt requires the FRACTDIR variable to be set in order to start."
+ elog "Please re-login or \`source /etc/profile\` to have this variable set."
+}