summaryrefslogtreecommitdiff
path: root/x11-misc/xearth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /x11-misc/xearth
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'x11-misc/xearth')
-rw-r--r--x11-misc/xearth/Manifest2
-rw-r--r--x11-misc/xearth/xearth-1.1-r1.ebuild43
2 files changed, 24 insertions, 21 deletions
diff --git a/x11-misc/xearth/Manifest b/x11-misc/xearth/Manifest
index 06cfb56f2f51..f999b144af23 100644
--- a/x11-misc/xearth/Manifest
+++ b/x11-misc/xearth/Manifest
@@ -1,4 +1,4 @@
AUX xearth-1.1-include.patch 231 BLAKE2B 803cdd036a1018ab85bd3acc30a6f6168a3596c04dd7de7196983b6c53b10e443d2ed043f61faa35b1ab87f28496f5865f128008b604efed41a74af3effc0d0e SHA512 9e4fd1d44eeda5c79ab22ceeb20fd005cab71869bcadd17adcb1cee10157c35145e7c7aa6d3c62f3da1be83cc79763b9ad77cfaddd4021dbcb56c8efcbccadb7
DIST xearth-1.1.tar.gz 157887 BLAKE2B 2dfc43b1a8fadeb7d30a4234496f44171cd138975e84b295e60d0f9855c1f3b011340b2b3aecb98d75fde2a71fdddb4e959ba84e89204f246915b7cd1a76efc1 SHA512 ab1c146385a0e61f6208a0218cabc8a10902f52feb50f328a330cdbddc5d2eff2c3efdf6719b625bcc07171ed2fd6201230ad8a71cd77a451ad9c81383bfd46e
-EBUILD xearth-1.1-r1.ebuild 873 BLAKE2B f3ed79afb2306ed7b166e00be122ceafb5a0affb325b78770dbec8e50a654a02f117a2c1064c15751bf1ab4e02b80d9c95b10440aaace158437d940d2c3af304 SHA512 c0f06f7772dfe7f7ffff190121b0bff693bfd286d7709ce4d4967445839af33f23488b0094cb46d5976a8b3ba52f3707f3922ac24443b43c4beb825d79ebe368
+EBUILD xearth-1.1-r1.ebuild 1000 BLAKE2B e5b4b46bf294cdc4eee5a6d657589b09679d9e512e49c0bcd5b8a9888c16dcadc0546455c7c99193e9cbbfdf61797f9e2a722312ed0dc37ae4219c6053ec46d4 SHA512 d93139097cb4ae343f7daab9d1bb120faf21c97fda5148c1832e5f744a2b2c1b8a58eac0e4bf4cf70f24dc11b16851d24b6f8791bdfa53901031482e4ed21c62
MISC metadata.xml 167 BLAKE2B e4dadf27fd344484f2bccb5b904909c89aac568c32e5b3c44bdf139eacefd4b4fae74419f503d2b7da0dccc1b68ba05d777d11292c0f89270d1ac5c9c703e8ca SHA512 7c8decb24ee3a850e38186cf3c7f8933a28017426806870ad6ef9ceb2533be147a2681fc789b535a81cb528af8c29d90d3006e4f250aee23bd7dea4561294e33
diff --git a/x11-misc/xearth/xearth-1.1-r1.ebuild b/x11-misc/xearth/xearth-1.1-r1.ebuild
index 52016d87ae19..542041ede4a8 100644
--- a/x11-misc/xearth/xearth-1.1-r1.ebuild
+++ b/x11-misc/xearth/xearth-1.1-r1.ebuild
@@ -1,47 +1,50 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
+DESCRIPTION="Set the X root window to an image of the Earth"
HOMEPAGE="https://hewgill.com/xearth/original/"
-DESCRIPTION="Xearth sets the X root window to an image of the Earth"
SRC_URI="ftp://cag.lcs.mit.edu/pub/tuna/${P}.tar.gz
ftp://ftp.cs.colorado.edu/users/tuna/${P}.tar.gz"
-SLOT="0"
LICENSE="xearth"
+SLOT="0"
KEYWORDS="~alpha amd64 ppc ppc64 x86"
-IUSE=""
RDEPEND="
x11-libs/libX11
x11-libs/libXext
- x11-libs/libXt
-"
-DEPEND="${RDEPEND}
- x11-base/xorg-proto
- x11-misc/imake
+ x11-libs/libXt"
+DEPEND="${RDEPEND}"
+BDEPEND="
app-text/rman
-"
+ x11-base/xorg-proto
+ >=x11-misc/imake-1.0.8-r1"
-src_prepare() {
- epatch "${FILESDIR}"/${P}-include.patch
-}
+PATCHES=(
+ "${FILESDIR}"/${P}-include.patch
+)
+DOCS=( BUILT-IN GAMMA-TEST HISTORY README )
src_configure() {
- xmkmf || die
+ CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
+ IMAKECPP="${IMAKECPP:-$(tc-getCPP)}" xmkmf || die
}
src_compile() {
- emake CC=$(tc-getCC) \
- CCOPTIONS="${CFLAGS}" \
+ local myemakeargs=(
+ CC="$(tc-getCC)"
+ CDEBUGFLAGS="${CFLAGS}"
EXTRA_LDOPTIONS="${LDFLAGS}"
+ )
+ emake "${myemakeargs[@]}"
}
src_install() {
- newman xearth.man xearth.1
dobin xearth
- dodoc BUILT-IN GAMMA-TEST HISTORY README
+ newman xearth.man xearth.1
+ einstalldocs
}