summaryrefslogtreecommitdiff
path: root/x11-misc/xdotool
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-11-13 13:10:00 +0000
commite9d044d4b9b71200a96adfa280848858c0f468c9 (patch)
tree1bd8ef816043a8cd340f1d774e79553a1a7d31d8 /x11-misc/xdotool
parentfc2f1018fc323ef2c6572734a9b130427cba76a6 (diff)
gentoo resync : 13.11.2021
Diffstat (limited to 'x11-misc/xdotool')
-rw-r--r--x11-misc/xdotool/Manifest2
-rw-r--r--x11-misc/xdotool/xdotool-3.20211022.1.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/x11-misc/xdotool/Manifest b/x11-misc/xdotool/Manifest
index b27971e9778d..5b180f7040c7 100644
--- a/x11-misc/xdotool/Manifest
+++ b/x11-misc/xdotool/Manifest
@@ -1,5 +1,7 @@
AUX xdotool-3.20210804.2-no_hardcoded_pkg-config.patch 1073 BLAKE2B 570221beabbad51f324bded0398afd68e9d3d4f30216b7a643dc9f8c76163721bd32778137fd322faffc2edafbc63d10cc036ec5311496b24410c737735f6482 SHA512 cb206c2b708835d8f3c656778edb07f08faafe3f9c1b407526e45321dc44b59981617b0c7b96865d6c1b968c855d40c0302ce888e8a1f57719b87ee9e774449e
AUX xdotool-3.20210804.2-no_ldconfig.patch 493 BLAKE2B 044f6896b2f1279795a4263107309886518698125a818522a771374f3a1f2242f00446e87eaaff3b5eead3840459fc249405d49d47e7cd6568f5c923e096fb34 SHA512 7b3d4fe4a532e81358d81ebe9fd6e212bcceb08700df37d7d4c7fc16d95177c8f39ec8ef5a986eb6a08e7c6d209efaa8426483732dcedec39617b203de2faac5
DIST xdotool-3.20210903.1.tar.gz 115051 BLAKE2B d1be4fc2f5c86991804b63b85c95748dc04098f85a515b3427d980dac3d355133da0408d3e91a39e5363ae6242b02d268a8b5bc014fdd5faf51e43e24fb54176 SHA512 446ba8d354031df6a21957df92220c7dcaae5bacbb8878568a57f31097db72a88701717ec8bcd35cca3f5356bfaf47eb3ed65d2159f03b0c7a7ae5550a9b1dce
+DIST xdotool-3.20211022.1.tar.gz 115237 BLAKE2B 1269775848905253936b113ac45e2a5126f1414eeacb5dd91aea6dc0cb6993f9fa0da969f30c83e0e03d435894a31ba633dc02269b38f9056772b513f0c86889 SHA512 f11d7b079f19d1650adfb549ecc96e840805935bf4925beefc3238154ad0afbff36b134c78bfc73a9dc07fc869ab75676575d6de50cfd54484d2c35d6913ea27
EBUILD xdotool-3.20210903.1.ebuild 1414 BLAKE2B 122aec097283e3d75980d9639d982719a0ce3af7501dd2877ffad27d7e17358a369913b4aaad97b04d5e7d46d4a0e88492b18bd17f49bebfab660b34e226faf1 SHA512 da30202930aef39942f58d6f1b9a24cfee833e4ec69f50f43c50d2fe0e1f49dc4f9d86d7b5722f3226ba7d8efcdccb35cd06af71e7f29ab4cb7c09254c05905c
+EBUILD xdotool-3.20211022.1.ebuild 1420 BLAKE2B b13faacc29a312ca24f1383d996bbb51b010fd85b1a5ba1111ca25aabf932feb133a219eccca1799f3dddaa089ffad206d6fb6ebbb7fcc58ba9e70e9b5416592 SHA512 fe201f408059102b92ad0d8ec894a7d4ac925bd16fd2df2889d6637323b448889656e6c575332b42caaf2343d7a8fc143615051efa74c803c9e5768a68fea931
MISC metadata.xml 560 BLAKE2B 9977cd6c5efe52174f07e4ef10141b7742c904c86afb7305ee82f9f222b2cf62a5b052f171f13d69cf3a7b00bf53f759f4cd108e7b285fafec5f5995828c0888 SHA512 381d5c1933c426b1847d2f239de60c68ec4877b482e6c33b60dffa74c7ff729cd5c62f852adcdf92b830ae8081f0b4c1a498b58416022f49bbae2013ca82ee74
diff --git a/x11-misc/xdotool/xdotool-3.20211022.1.ebuild b/x11-misc/xdotool/xdotool-3.20211022.1.ebuild
new file mode 100644
index 000000000000..849e4a9503b1
--- /dev/null
+++ b/x11-misc/xdotool/xdotool-3.20211022.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Simulate keyboard input and mouse activity, move and resize windows"
+HOMEPAGE="https://www.semicomplete.com/projects/xdotool/"
+SRC_URI="https://github.com/jordansissel/xdotool/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="examples"
+
+# Many the tests want to manually start Xvfb regardless of whether there
+# is an X server running or not (i.e. does not play nicely with virtualx),
+# some tests require x11-wm/openbox, some try to run a complete Gnome
+# session. All of them require a Ruby interpreter with dev-ruby/minitest
+# installed. In short, supporting tests here will need MUCH work.
+RESTRICT="test"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libXtst
+ x11-libs/libxkbcommon"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ x11-base/xorg-proto"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.20210804.2-no_hardcoded_pkg-config.patch
+ "${FILESDIR}"/${PN}-3.20210804.2-no_ldconfig.patch
+)
+
+DOCS=( CHANGELIST README.md )
+
+src_compile() {
+ tc-export CC LD PKG_CONFIG
+ emake PREFIX="${EPREFIX}/usr"
+}
+
+src_install() {
+ emake PREFIX="${ED}/usr" INSTALLMAN="${ED}/usr/share/man" INSTALLLIB="${ED}/usr/$(get_libdir)" install
+
+ use examples && DOCS+=( examples )
+ einstalldocs
+}