summaryrefslogtreecommitdiff
path: root/x11-misc/xbindkeys
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-19 12:11:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-19 12:11:50 +0100
commitfe0961fc9674dd24a017f474a34c1edbbd005965 (patch)
treedfdf05888e0f5fff9c1faafe6eb0dd5d827b63e5 /x11-misc/xbindkeys
parentbcd00c826070701606b0ccebf46234dfc792d3e9 (diff)
gentoo auto-resync : 19:09:2024 - 12:11:50
Diffstat (limited to 'x11-misc/xbindkeys')
-rw-r--r--x11-misc/xbindkeys/Manifest1
-rw-r--r--x11-misc/xbindkeys/xbindkeys-1.8.7-r100.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/x11-misc/xbindkeys/Manifest b/x11-misc/xbindkeys/Manifest
index fa5d0f3c8ff1..0ab5f7d830a4 100644
--- a/x11-misc/xbindkeys/Manifest
+++ b/x11-misc/xbindkeys/Manifest
@@ -1,3 +1,4 @@
DIST xbindkeys-1.8.7.tar.gz 177532 BLAKE2B 9ff6c9cd10bb6f2bf96a288482edb50e6671c9e4e3b5c136bdfaa92796f9e9bcfc42ab69ca3546c3871bdcdba1e952631cbd3d288dce9738986c20680e91c316 SHA512 a6b1478e8ef4bedc686fdd15abc11a8a592ac17c69e1a5a13f60e735e9be9646faed62e980cdac4aa7bc7e3253237465de38dee98935dd3f9911d4e48209b2e9
+EBUILD xbindkeys-1.8.7-r100.ebuild 1005 BLAKE2B 7627fc8f284ca97b1903ca7d04ff60e1f5598080f26002c00e076704aee651041ede44d20daec588dd41e26520491cff3b171cc837841cc8478e39d3bb0ed1a6 SHA512 5e17f64c01b6c6980a6237c3c8059ec6637d3d6f93231a13941ed4f3a64a64151d44188042c5d487e074539e91b5df45c1d92af5b478ddffd642777ae048f6d3
EBUILD xbindkeys-1.8.7-r2.ebuild 813 BLAKE2B 4edf6b5bdcc6056bdaa1d56a173a9fd406c7b6e4edd1430b84ad4d34cb92d568392bcbd6f2a9cef51b24914b42dd8af498a4c1493117e637915c2bc60ba3ef52 SHA512 93c71aa19ba60601bc0642f00b2330c8c8f862f3e04bd90d1560302e6e37df26f7d5ca68ef8edf5855786723af8421782111fbdcdd9999e0fffd0fc922843c84
MISC metadata.xml 388 BLAKE2B 8627eaf1867246255f9cf5e886749300fe854b6fc4add00c1fb7395a41349a42aeaf9bcd1866b1ef8a6b3ecd04416cd6ebb7dcebd266ae341af4aaa144de510d SHA512 238ec6ad37a6fcb588eeb6f5f00befa9e9f483cbd012d7e98b9627a3bf3f401ea74aee560a1909458a471e6c44b3ea13eb3a7d30e5f5a1f5c5464c9775d5614d
diff --git a/x11-misc/xbindkeys/xbindkeys-1.8.7-r100.ebuild b/x11-misc/xbindkeys/xbindkeys-1.8.7-r100.ebuild
new file mode 100644
index 000000000000..4688b3dae019
--- /dev/null
+++ b/x11-misc/xbindkeys/xbindkeys-1.8.7-r100.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+GUILE_REQ_USE="deprecated"
+GUILE_COMPAT=( 2-2 3-0 )
+inherit autotools guile-single
+
+DESCRIPTION="Tool for launching commands on keystrokes"
+SRC_URI="https://www.nongnu.org/${PN}/${P}.tar.gz"
+HOMEPAGE="https://www.nongnu.org/xbindkeys/xbindkeys.html"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="guile tk"
+
+REQUIRED_USE="guile? ( ${GUILE_REQUIRED_USE} )"
+
+RDEPEND="
+ x11-libs/libX11
+ guile? ( ${GUILE_DEPS} )
+ tk? ( dev-lang/tk )
+"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+
+DOCS=( AUTHORS BUGS ChangeLog README TODO xbindkeysrc )
+
+src_prepare() {
+ default
+
+ use guile && guile_bump_sources
+
+ # Regenerate to pick up newer versions of Guile macros
+ # bug #828532
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable guile) \
+ $(use_enable tk)
+}
+
+src_install() {
+ default
+
+ use guile && guile_unstrip_ccache
+}