summaryrefslogtreecommitdiff
path: root/x11-misc/x2vnc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-29 09:22:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-29 09:22:29 +0100
commitb94ab464dd0d948b7e7eac833b9bb51c03515918 (patch)
tree130d52181c215cd1c3eced88bc503353a99a1fe8 /x11-misc/x2vnc
parent62ea91b40c7650011a72ed2443f76b88b06123fe (diff)
gentoo auto-resync : 29:09:2022 - 09:22:29
Diffstat (limited to 'x11-misc/x2vnc')
-rw-r--r--x11-misc/x2vnc/Manifest3
-rw-r--r--x11-misc/x2vnc/files/x2vnc-1.7.2-clang16.patch33
-rw-r--r--x11-misc/x2vnc/x2vnc-1.7.2-r2.ebuild (renamed from x11-misc/x2vnc/x2vnc-1.7.2-r1.ebuild)25
3 files changed, 51 insertions, 10 deletions
diff --git a/x11-misc/x2vnc/Manifest b/x11-misc/x2vnc/Manifest
index cf40526d8174..8964838181f6 100644
--- a/x11-misc/x2vnc/Manifest
+++ b/x11-misc/x2vnc/Manifest
@@ -1,4 +1,5 @@
AUX expectk.patch 410 BLAKE2B 4e3f8882adbc64fc6c152394cdeed792a9630637e9962803a6ba5fbe9da5daa792024663cbe6192089a11bf18c51c088ef85d5d5928b174bc0caeb194f591183 SHA512 bb1dacf7d14e4a2d12ddcbe46029b912f781970f054f3127a23574bb290d26688d4a6fdc894dd5ef8d5d29474e5cae4b478e8618d2d2ccbf4043c9df7919312d
+AUX x2vnc-1.7.2-clang16.patch 626 BLAKE2B 2c61be8d79887d75c9b88b3ddaf7aee7f2e273b4b3a359e24c36e0568ade9718be879b8d0e97c19658ddb18882978cde0ef278f8c9bf64b5ab80e1a8fb63c36e SHA512 a1abd6c58fa409957ec2b9dcbb257c633cd94e93818d251ac0c18c7d6290a90f95be7a5a181695364b6a2eb3f85946c46c4d4538a6f616cacbaaf85bb7e858f9
DIST x2vnc-1.7.2.tar.gz 82258 BLAKE2B 4eebf2f33a38ac3fefc4b5a2a527977ad5dc73d0e3e8c289bffb2c0be1ca01117bbef5c312e186f295c910cbed0c71bea82cba8aaedb2cbbb192795d8eac9133 SHA512 f9bb9f8b95a6172758d1fd8b97f235088f0815afa21f2e11db77e59b36f8b3fe2fa2d8b922b14ccde1c589851d80489c9fd81d9f734ca9b053e4bc4019eade0b
-EBUILD x2vnc-1.7.2-r1.ebuild 680 BLAKE2B 505e797e5f94999ddfa7d0e2a1c9a539f04960caf28a76227cef3540587e8570e4a0f8a40e3c7996cfc28f63463c1069d02b5ecef8e7e1da86edd805345a06df SHA512 363c755dbbcd96e71b1bed42ff28ac51fd03143283c63b3ac012a0cc1801b686633fbe10d5d5904b379b0571cf6a7ff73cdc388b5d0adec55da1d54bc3308881
+EBUILD x2vnc-1.7.2-r2.ebuild 803 BLAKE2B 5678305c969c2699b828372488466f611b061ed90cffc863d247c04c912fa8b256ade01110500d3e3a6feacd73e4a725873ca3d8a1bcac2cfb208a60bacbb170 SHA512 5d8fcdeae5c37cca565a3f2c96ed2f9574aba49ddb0e024208600b9b2b87fd97c54c937761329f0651db3c962da7812db87527c97f23ed8bba4ae3682f7e1757
MISC metadata.xml 273 BLAKE2B e41a84edc2f2bf01256d6c759fec49da44a20e3d595a6fe56f96239ab26213551ae190621a5e8f9523b777c42364680fd61a6423b08eada73b97eb4e81253dd7 SHA512 985a49dc2d598b61be8510f6f86c4894825a56392af613ecdc68de499242f1e7e910f8320e0fd0540bc5f42dde80a4f0b18b6919320ee60aa39da1441c147274
diff --git a/x11-misc/x2vnc/files/x2vnc-1.7.2-clang16.patch b/x11-misc/x2vnc/files/x2vnc-1.7.2-clang16.patch
new file mode 100644
index 000000000000..7b9cd1b50b69
--- /dev/null
+++ b/x11-misc/x2vnc/files/x2vnc-1.7.2-clang16.patch
@@ -0,0 +1,33 @@
+https://bugs.gentoo.org/870652
+--- a/rfbproto.c
++++ b/rfbproto.c
+@@ -25,2 +25,4 @@
+
++#include <ctype.h>
++#include <time.h>
+ #include <unistd.h>
+--- a/sockets.c
++++ b/sockets.c
+@@ -33,2 +33,3 @@
+ void PrintInHex(char *buf, int len);
++int tunnel(char *gatewayhost, char *remotehost, int remoteport);
+
+--- a/vncauth.c
++++ b/vncauth.c
+@@ -28,2 +28,4 @@
+ #include <sys/stat.h>
++#include <time.h>
++#include <unistd.h>
+ #include <vncauth.h>
+--- a/x.c
++++ b/x.c
+@@ -26,2 +26,3 @@
+ #include <sys/types.h>
++#include <time.h>
+ #include <unistd.h>
+--- a/x2vnc.c
++++ b/x2vnc.c
+@@ -25,2 +25,3 @@
+
++#include <time.h>
+ #include <unistd.h>
diff --git a/x11-misc/x2vnc/x2vnc-1.7.2-r1.ebuild b/x11-misc/x2vnc/x2vnc-1.7.2-r2.ebuild
index b9d93cf24e77..03384930c47f 100644
--- a/x11-misc/x2vnc/x2vnc-1.7.2-r1.ebuild
+++ b/x11-misc/x2vnc/x2vnc-1.7.2-r2.ebuild
@@ -1,27 +1,34 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
DESCRIPTION="Control a remote computer running VNC from X"
-HOMEPAGE="http://fredrik.hubbe.net/x2vnc.html"
-SRC_URI="http://fredrik.hubbe.net/${PN}/${P}.tar.gz"
+HOMEPAGE="https://fredrik.hubbe.net/x2vnc.html"
+SRC_URI="https://fredrik.hubbe.net/x2vnc/${P}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~alpha amd64 ppc sparc x86"
IUSE="tk"
-RDEPEND="x11-libs/libX11
+COMMON_DEPEND="
+ x11-libs/libX11
x11-libs/libXScrnSaver
x11-libs/libXext
- x11-libs/libXinerama"
-DEPEND="${RDEPEND}
- x11-base/xorg-proto
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libXxf86dga"
+RDEPEND="
+ ${COMMON_DEPEND}
tk? ( dev-tcltk/expect )"
+DEPEND="
+ ${COMMON_DEPEND}
+ x11-base/xorg-proto"
PATCHES=(
- "${FILESDIR}/expectk.patch"
+ "${FILESDIR}"/expectk.patch
+ "${FILESDIR}"/${P}-clang16.patch
)
src_install() {