summaryrefslogtreecommitdiff
path: root/x11-misc/trayer-srg
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /x11-misc/trayer-srg
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'x11-misc/trayer-srg')
-rw-r--r--x11-misc/trayer-srg/Manifest1
-rw-r--r--x11-misc/trayer-srg/trayer-srg-1.1.8-r1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/x11-misc/trayer-srg/Manifest b/x11-misc/trayer-srg/Manifest
index 1373e148f151..05e2ae154d17 100644
--- a/x11-misc/trayer-srg/Manifest
+++ b/x11-misc/trayer-srg/Manifest
@@ -1,3 +1,4 @@
DIST trayer-srg-1.1.8.tar.gz 28025 BLAKE2B 3eca8faf7237e1941a611a85a4460310dda1a8d89cb96ae2ac7d77c47a7f8b4fa4bb1a2bcc549fef285ca14a74dce23d9af1b349bb5b0ff9d3bf4abe1ed06351 SHA512 5ae92fdcee64ad1ca59846874dcd4bd4859adeeb80a86f1ed97d62e6306f8ec62d1ee26dba251257242dc25d158a6a550e69f2fcc8739242a2311e37fe1ce310
+EBUILD trayer-srg-1.1.8-r1.ebuild 735 BLAKE2B 476a7e17f61a8715bb184bdfa1a4bb6e2d89ec9035ad24bfcbf716dd734be99d33ca752e02d95cd9f9a4914cb4e218f97a951168fe58aed51b96220299adaef6 SHA512 2a8bb681a9f846eb2cd318de2fd3a65991def69888145884b55243aa1e851fa0259ef6ffd4a7d8c4b3e6bc9dc4579d7ec99beb9ffefbd32f02145f23a9bb6549
EBUILD trayer-srg-1.1.8.ebuild 751 BLAKE2B c28bb22c25f7f8193003ae7a6a7651c6b9abbc22cba56da51861f1344c7a9626ed110bb7cb3753c502a0b330edec5771200f6c555de79725430b736b0a1bc57a SHA512 ebb0a9169a3119a715003c0b6a0edc79b5a4cfe5f4cb23ff073b46f1e990c472fda0cef02e8f9ae8f8f3ba4b2b038fb68eae206b5ae1190026b9637693e5a03d
MISC metadata.xml 250 BLAKE2B 183552a2f861b4003230edf6c0eb30cf21c4fcb91ee7ab4df15980e9d75162431aa6e3fee0849aa657ce63c4234b9e453f702e8a6bed3670942290fba9c7cf3b SHA512 a01fbd281bd274d9714e95cf2d59840bdb983b5eebd9ddbfdfea6b2144cb15ef48919a0974c73f28c87d5b4a91f4b5e071665ef3ab0ee827a27414362b674613
diff --git a/x11-misc/trayer-srg/trayer-srg-1.1.8-r1.ebuild b/x11-misc/trayer-srg/trayer-srg-1.1.8-r1.ebuild
new file mode 100644
index 000000000000..5e24fffa7f07
--- /dev/null
+++ b/x11-misc/trayer-srg/trayer-srg-1.1.8-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="trayer fork with multi monitor support and cleaned up codebase"
+HOMEPAGE="https://github.com/sargon/trayer-srg"
+SRC_URI="https://github.com/sargon/${PN}/archive/${P/-srg/}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ x11-libs/gdk-pixbuf:2
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+ x11-libs/libX11
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}"/${PN}-trayer-${PV}
+
+src_configure() {
+ ./configure --prefix="${EPREFIX}" || die
+}
+
+src_compile() {
+ emake TARGET=${PN} CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin ${PN}
+ einstalldocs
+}