summaryrefslogtreecommitdiff
path: root/x11-misc/tdrop
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /x11-misc/tdrop
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'x11-misc/tdrop')
-rw-r--r--x11-misc/tdrop/Manifest4
-rw-r--r--x11-misc/tdrop/tdrop-0.4.0.ebuild38
-rw-r--r--x11-misc/tdrop/tdrop-9999.ebuild2
3 files changed, 42 insertions, 2 deletions
diff --git a/x11-misc/tdrop/Manifest b/x11-misc/tdrop/Manifest
index 138d55180cce..a711a1b2bf77 100644
--- a/x11-misc/tdrop/Manifest
+++ b/x11-misc/tdrop/Manifest
@@ -1,4 +1,6 @@
DIST tdrop-0.3.0.tar.gz 19495 BLAKE2B 5f72090e6ccacaa4f708715cb1a2eb43bb8acec79f43301da67dbe0a8d81637806603d06b9ad0b2815e8aea1f481271f5b8f8adddba60079ad48ec621f8e8e8f SHA512 3e1c30e42ce96570fabd43b89fd9f17a23d74c4943ef9ab5d1edb4967ffa6c4c0259df4449ef2a18b396d1057f4a19a413fec817ff708d3e41906695cebb67ca
+DIST tdrop-0.4.0.tar.gz 21550 BLAKE2B 673ad98aa294410b4547fce842d191fd3c5512cca79361cae35fcb646afd328615daab1fa112bcba9e28cdea6bbeb2ca696bcc78d54c0302d32a91324a8a16d9 SHA512 679fed509e29752ebe3df378e68d9701c9edb53c9162854a8cb623f2da53499b933dad59fa6fc865ac44c67544cd6bcb779316ee4312e87c39559ade1ab313d8
EBUILD tdrop-0.3.0.ebuild 651 BLAKE2B c7843a495947365d6b79c223f564144f02aece7c935ef112df23d43d9a7e4c9f388f96dbc430e3483d0a865663343de835f14cceb5d4fc8443421e526cdbd8f1 SHA512 e4765fe0fc68f0050b154b247643265552745e2662717cea86cbbace80487c6cbf7bf47105dc796a4d5f00b6e5dad510ad0d3cd46a0a0b83efa40bcf85bd3026
-EBUILD tdrop-9999.ebuild 651 BLAKE2B c7843a495947365d6b79c223f564144f02aece7c935ef112df23d43d9a7e4c9f388f96dbc430e3483d0a865663343de835f14cceb5d4fc8443421e526cdbd8f1 SHA512 e4765fe0fc68f0050b154b247643265552745e2662717cea86cbbace80487c6cbf7bf47105dc796a4d5f00b6e5dad510ad0d3cd46a0a0b83efa40bcf85bd3026
+EBUILD tdrop-0.4.0.ebuild 656 BLAKE2B e3f23ec203d5229d468cfaacda7fce752a5e7c8361e259339f0df2298ddf9de10010484fd0adf639d2a4365537ba7648cfeac32fa9433c073339e4e2eaea7f2d SHA512 e0536af8897c34b2716a31516b18a1d3534593019035d30105db04fc733ccdf8de48feb5e1cdaca169d4dadc602c3c89801c45edf8d7b1051c92d82dc0c660ad
+EBUILD tdrop-9999.ebuild 656 BLAKE2B e3f23ec203d5229d468cfaacda7fce752a5e7c8361e259339f0df2298ddf9de10010484fd0adf639d2a4365537ba7648cfeac32fa9433c073339e4e2eaea7f2d SHA512 e0536af8897c34b2716a31516b18a1d3534593019035d30105db04fc733ccdf8de48feb5e1cdaca169d4dadc602c3c89801c45edf8d7b1051c92d82dc0c660ad
MISC metadata.xml 328 BLAKE2B ae4f7167469dea0110c2f60a6853d8418bbff6ddeda3f9750175ade25f750a9e3d165aa5882b697ed35b93749ccae82dadce5b7a6b9c7c5656929286519fbe6b SHA512 9c27673aca0b343a620efad5cdb0dbdc1216cd839672abc94d37066fa4a4e095e2d86464495acc79d391f4d1de207ca9d17bbd705066fcd636b66bc6e8a3b1dc
diff --git a/x11-misc/tdrop/tdrop-0.4.0.ebuild b/x11-misc/tdrop/tdrop-0.4.0.ebuild
new file mode 100644
index 000000000000..695b437b87d3
--- /dev/null
+++ b/x11-misc/tdrop/tdrop-0.4.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2019-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="WM-Independent Dropdown Creator"
+HOMEPAGE="https://github.com/noctuid/tdrop"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/noctuid/tdrop"
+else
+ SRC_URI="https://github.com/noctuid/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc64"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ app-shells/bash
+ sys-process/procps
+ x11-apps/xprop
+ x11-apps/xrandr
+ x11-apps/xwininfo
+ x11-misc/xdotool
+"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ dobin tdrop
+ doman tdrop.1
+ dodoc README.org
+}
diff --git a/x11-misc/tdrop/tdrop-9999.ebuild b/x11-misc/tdrop/tdrop-9999.ebuild
index 1031384a291e..695b437b87d3 100644
--- a/x11-misc/tdrop/tdrop-9999.ebuild
+++ b/x11-misc/tdrop/tdrop-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 2019 Gentoo Authors
+# Copyright 2019-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7