summaryrefslogtreecommitdiff
path: root/x11-misc/tdrop
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /x11-misc/tdrop
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'x11-misc/tdrop')
-rw-r--r--x11-misc/tdrop/Manifest4
-rw-r--r--x11-misc/tdrop/metadata.xml11
-rw-r--r--x11-misc/tdrop/tdrop-0.3.0.ebuild38
-rw-r--r--x11-misc/tdrop/tdrop-9999.ebuild38
4 files changed, 91 insertions, 0 deletions
diff --git a/x11-misc/tdrop/Manifest b/x11-misc/tdrop/Manifest
new file mode 100644
index 000000000000..138d55180cce
--- /dev/null
+++ b/x11-misc/tdrop/Manifest
@@ -0,0 +1,4 @@
+DIST tdrop-0.3.0.tar.gz 19495 BLAKE2B 5f72090e6ccacaa4f708715cb1a2eb43bb8acec79f43301da67dbe0a8d81637806603d06b9ad0b2815e8aea1f481271f5b8f8adddba60079ad48ec621f8e8e8f SHA512 3e1c30e42ce96570fabd43b89fd9f17a23d74c4943ef9ab5d1edb4967ffa6c4c0259df4449ef2a18b396d1057f4a19a413fec817ff708d3e41906695cebb67ca
+EBUILD tdrop-0.3.0.ebuild 651 BLAKE2B c7843a495947365d6b79c223f564144f02aece7c935ef112df23d43d9a7e4c9f388f96dbc430e3483d0a865663343de835f14cceb5d4fc8443421e526cdbd8f1 SHA512 e4765fe0fc68f0050b154b247643265552745e2662717cea86cbbace80487c6cbf7bf47105dc796a4d5f00b6e5dad510ad0d3cd46a0a0b83efa40bcf85bd3026
+EBUILD tdrop-9999.ebuild 651 BLAKE2B c7843a495947365d6b79c223f564144f02aece7c935ef112df23d43d9a7e4c9f388f96dbc430e3483d0a865663343de835f14cceb5d4fc8443421e526cdbd8f1 SHA512 e4765fe0fc68f0050b154b247643265552745e2662717cea86cbbace80487c6cbf7bf47105dc796a4d5f00b6e5dad510ad0d3cd46a0a0b83efa40bcf85bd3026
+MISC metadata.xml 328 BLAKE2B ae4f7167469dea0110c2f60a6853d8418bbff6ddeda3f9750175ade25f750a9e3d165aa5882b697ed35b93749ccae82dadce5b7a6b9c7c5656929286519fbe6b SHA512 9c27673aca0b343a620efad5cdb0dbdc1216cd839672abc94d37066fa4a4e095e2d86464495acc79d391f4d1de207ca9d17bbd705066fcd636b66bc6e8a3b1dc
diff --git a/x11-misc/tdrop/metadata.xml b/x11-misc/tdrop/metadata.xml
new file mode 100644
index 000000000000..e22c540bc283
--- /dev/null
+++ b/x11-misc/tdrop/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>gyakovlev@gentoo.org</email>
+ <name>Georgy Yakovlev</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">octuid/tdrop</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-misc/tdrop/tdrop-0.3.0.ebuild b/x11-misc/tdrop/tdrop-0.3.0.ebuild
new file mode 100644
index 000000000000..1031384a291e
--- /dev/null
+++ b/x11-misc/tdrop/tdrop-0.3.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="WM-Independent Dropdown Creator"
+HOMEPAGE="https://github.com/noctuid/tdrop"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/noctuid/tdrop"
+else
+ SRC_URI="https://github.com/noctuid/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc64"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ app-shells/bash
+ sys-process/procps
+ x11-apps/xprop
+ x11-apps/xrandr
+ x11-apps/xwininfo
+ x11-misc/xdotool
+"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ dobin tdrop
+ doman tdrop.1
+ dodoc README.org
+}
diff --git a/x11-misc/tdrop/tdrop-9999.ebuild b/x11-misc/tdrop/tdrop-9999.ebuild
new file mode 100644
index 000000000000..1031384a291e
--- /dev/null
+++ b/x11-misc/tdrop/tdrop-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="WM-Independent Dropdown Creator"
+HOMEPAGE="https://github.com/noctuid/tdrop"
+
+if [[ ${PV} == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/noctuid/tdrop"
+else
+ SRC_URI="https://github.com/noctuid/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~ppc64"
+fi
+
+LICENSE="BSD-2"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+ app-shells/bash
+ sys-process/procps
+ x11-apps/xprop
+ x11-apps/xrandr
+ x11-apps/xwininfo
+ x11-misc/xdotool
+"
+
+src_compile() {
+ :
+}
+
+src_install() {
+ dobin tdrop
+ doman tdrop.1
+ dodoc README.org
+}