summaryrefslogtreecommitdiff
path: root/x11-misc/sxhkd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /x11-misc/sxhkd
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'x11-misc/sxhkd')
-rw-r--r--x11-misc/sxhkd/Manifest2
-rw-r--r--x11-misc/sxhkd/sxhkd-0.6.2-r1.ebuild (renamed from x11-misc/sxhkd/sxhkd-0.6.2.ebuild)21
2 files changed, 16 insertions, 7 deletions
diff --git a/x11-misc/sxhkd/Manifest b/x11-misc/sxhkd/Manifest
index f2056e9ce6b7..ff01ef0b23fb 100644
--- a/x11-misc/sxhkd/Manifest
+++ b/x11-misc/sxhkd/Manifest
@@ -1,3 +1,3 @@
DIST sxhkd-0.6.2.tar.gz 35711 BLAKE2B a1dc409314dda68aa3df99bf584d20e492c7220dceb188b844a6bd9374a4c52b7e1a406b96fc77276498db86dd5e5114a50357ddee660f5f08d6fe974de8f990 SHA512 3f758aec3de76c6336a9008e997317ed7a05db0fcd81025d8f856694c2b8162022e25d9a48876de99056748a2dbe6a561a0e1594973c854ac2c98d44af6b03aa
-EBUILD sxhkd-0.6.2.ebuild 667 BLAKE2B 7f066bf4563c1bedb2ca00c383cc4f9fc85ade14c1241ca6ecc07eb947d2273aae67ec8c08dcd8d085afa6fa69900c2299cf0b104a4e9be0e4b4e1b01b6aa2ee SHA512 32c4aaa0cf8020a71edeadda136db6a124c91ddb3d14898c09011060e536bbe2b5a58fd913bdf94196c676ee810ca1d09fcb6b20e9db740282b4fb4628b776ad
+EBUILD sxhkd-0.6.2-r1.ebuild 720 BLAKE2B d8aff4f4c3795fecc1ada514c540d2bade213ed3ebe67160305d1b57a13731ddee756654060f68a1acf7cbd184575517a3152f6f32fecafbb8272bd3ca1e0bff SHA512 e8a9b59cefed39df3ea5632a1aec4b32472834b591094d4a52b36746681ade4cc3b8eb6b7b9d0d428629194fbab6e58d41195dc4e816a5d6b1b6231488d1ac2e
MISC metadata.xml 328 BLAKE2B ef5ee0d2400003eedf0d3a6371233fd6dee54b0c372458c25c14754959f7553731ce8a989029fe23462afcdd0a5d184a23808e619c465c483c1b8e72a77a6f48 SHA512 3ef7078052da12bb622dd64e3c6df6ede3e271953a2e9bfe49288a19d862e22bd085cd0b1aafd6e7bb16cdb9deae4d63c293f40f62ea4a0abc23b248df091a00
diff --git a/x11-misc/sxhkd/sxhkd-0.6.2.ebuild b/x11-misc/sxhkd/sxhkd-0.6.2-r1.ebuild
index 62e4eb5b3616..83ed6a4db2ef 100644
--- a/x11-misc/sxhkd/sxhkd-0.6.2.ebuild
+++ b/x11-misc/sxhkd/sxhkd-0.6.2-r1.ebuild
@@ -1,7 +1,8 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
+
inherit toolchain-funcs systemd
DESCRIPTION="Simple X hotkey daemon"
@@ -10,11 +11,13 @@ SRC_URI="https://github.com/baskerville/sxhkd/archive/${PV}.tar.gz -> ${P}.tar.g
LICENSE="BSD-2"
SLOT="0"
-KEYWORDS="amd64 ~riscv ~x86"
+KEYWORDS="amd64 ~riscv x86"
-RDEPEND="x11-libs/libxcb
+RDEPEND="
+ x11-libs/libxcb:=
x11-libs/xcb-util-keysyms"
-DEPEND="${RDEPEND}
+DEPEND="
+ ${RDEPEND}
x11-libs/xcb-util"
src_compile() {
@@ -22,6 +25,12 @@ src_compile() {
}
src_install() {
- emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" DOCPREFIX="${EPREFIX}/usr/share/doc/${PF}" install
+ local emakeargs=(
+ DESTDIR="${D}"
+ PREFIX="${EPREFIX}"/usr
+ DOCPREFIX="${EPREFIX}"/usr/share/doc/${PF}
+ )
+ emake "${emakeargs[@]}" install
+
systemd_dounit contrib/systemd/${PN}.service
}