summaryrefslogtreecommitdiff
path: root/x11-misc/sunflower/sunflower-0.5-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-18 02:33:38 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-18 02:33:38 +0100
commitb5408a0879b82101f69b6bf3bc29b6e9e4969941 (patch)
tree476433e68266a2cc5100b7d966badf13755311c8 /x11-misc/sunflower/sunflower-0.5-r1.ebuild
parent83b5cde41ddb8fd20de4536dd68eb08da42d013e (diff)
gentoo auto-resync : 18:07:2022 - 02:33:38
Diffstat (limited to 'x11-misc/sunflower/sunflower-0.5-r1.ebuild')
-rw-r--r--x11-misc/sunflower/sunflower-0.5-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-misc/sunflower/sunflower-0.5-r1.ebuild b/x11-misc/sunflower/sunflower-0.5-r1.ebuild
new file mode 100644
index 000000000000..e019671e4ced
--- /dev/null
+++ b/x11-misc/sunflower/sunflower-0.5-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_REQ_USE="sqlite"
+inherit distutils-r1 xdg
+
+MY_PN="Sunflower"
+MY_PV="${PV}-63"
+
+DESCRIPTION="Small and highly customizable twin-panel file manager with plugin-support"
+HOMEPAGE="https://github.com/MeanEYE/Sunflower
+ https://sunflower-fm.org/"
+SRC_URI="https://github.com/MeanEYE/${MY_PN}/archive/refs/tags/${MY_PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ ${PYTHON_DEPS}
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+"
+
+RDEPEND="${DEPEND}
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ x11-libs/vte
+"
+
+S="${WORKDIR}/${MY_PN}-${MY_PV}"
+
+src_prepare() {
+ default
+
+ # Upstream's get_version requires a lot of BDEPENDS we do not want.
+ sed 's%version=get_version()%version="0.5"%g' -i setup.py
+}