summaryrefslogtreecommitdiff
path: root/x11-misc/slop
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /x11-misc/slop
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'x11-misc/slop')
-rw-r--r--x11-misc/slop/Manifest4
-rw-r--r--x11-misc/slop/slop-7.5.ebuild43
-rw-r--r--x11-misc/slop/slop-9999.ebuild4
3 files changed, 49 insertions, 2 deletions
diff --git a/x11-misc/slop/Manifest b/x11-misc/slop/Manifest
index 6ee7d94b6a41..c48634512f13 100644
--- a/x11-misc/slop/Manifest
+++ b/x11-misc/slop/Manifest
@@ -1,4 +1,6 @@
DIST slop-7.4.tar.gz 50079 BLAKE2B 20815270bf1bffe0ef26630fd31d0d4cc7261633cef389e64c232a89033b6e8b5e1651fb5c882e2870808107734c4c088123b85675fa2aae932570d770344dc8 SHA512 13d09c2c9f05760ee0a273edb6d40da8a87989d3f071a8c868a0c7e535ba89b9eb934c79d56212cd689687f86e3683cef1b749ef7b37be3805ea8eb05c796e58
+DIST slop-7.5.tar.gz 51060 BLAKE2B 8d0fcf932181dfc482be7c54cf5a08605a32c85bcd8b27223a4cd8a08323382e802a7f20faa6c51fe67583b1d320cf783c7b5cc8b871e534ea11a32b827e1f45 SHA512 c02e40c5b924841996617fcc9629a6a739a04b6128c18e1eb06dc285d2f8026d847e67077fb59a111fc45c112f871a6e5faef20108c3d777271e1d4aca7f4737
EBUILD slop-7.4.ebuild 841 BLAKE2B e9d7a1c367746cf7755c53e6e67b49350636a9e492fb4925227301e3bbd75b7fff0305cdcb5d44c0d68545677770b5cc286e9762c68da9175379bb4b0856cb04 SHA512 2d488df26b6f1c39539d9eba88baa621a6166b53b30ec30d68bda1eb617dbd9da5b17d74a2fffc5193012141e1e3a68c180ed6d62d3703dd26d35eab4410e078
-EBUILD slop-9999.ebuild 785 BLAKE2B ec4f42dd28595eac50293489235b2eea52adf49a71f37417e20a6f1110b847ab06ce56b77d44f7ae2b66ce1a657667b3d900b8d473d5a6d6ee4d769380082ddb SHA512 5d67f66c0d85e385f79fbde652ea225b25a360df13bb49330b11ffcd2831701566f309e22166df015e8738ecd637abc69fb610fe3c02506bc6e249372f9fafa1
+EBUILD slop-7.5.ebuild 808 BLAKE2B 98fbd3f0b5395b71b11c07a235aa3358a3723a346876dbc88487335b1ed74e552e6ca15bf55d01d54f47b275ada783e3177a359d542b4c74ec03b24a4a9f4e6e SHA512 92c9f8c8920abfc9e321cbdbe4788cc35a470bac8e83fc3f278e2eb63faf05896d07fb6d1f5a323455597c0c15bad731828aa240764e9805526f05dd27dce6b2
+EBUILD slop-9999.ebuild 808 BLAKE2B 98fbd3f0b5395b71b11c07a235aa3358a3723a346876dbc88487335b1ed74e552e6ca15bf55d01d54f47b275ada783e3177a359d542b4c74ec03b24a4a9f4e6e SHA512 92c9f8c8920abfc9e321cbdbe4788cc35a470bac8e83fc3f278e2eb63faf05896d07fb6d1f5a323455597c0c15bad731828aa240764e9805526f05dd27dce6b2
MISC metadata.xml 630 BLAKE2B dbf7d848908c12d7104c7cd18cd2ca16114073803bd4600e10906a1fc4f86ddeb646359d26885551d998a279d1e11f0d74ad21b135e14a2bea827ef21ade15f7 SHA512 98eea5cce0e8a692076b5cb423a2f0522151d716ef0c9f346e915bfee8590d32dab59c183180ea7f87561bfb92e3840ad710f890a734640173bbcd471d779b0e
diff --git a/x11-misc/slop/slop-7.5.ebuild b/x11-misc/slop/slop-7.5.ebuild
new file mode 100644
index 000000000000..a9c376b256ec
--- /dev/null
+++ b/x11-misc/slop/slop-7.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Application that queries the user for a selection for printing"
+HOMEPAGE="https://github.com/naelstrof/slop"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/naelstrof/slop.git"
+else
+ SRC_URI="https://github.com/naelstrof/slop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0/${PV}"
+IUSE="opengl"
+
+RDEPEND="
+ dev-libs/icu:=
+ x11-libs/libX11
+ x11-libs/libXext
+ opengl? (
+ media-libs/glew:0=
+ media-libs/libglvnd
+ virtual/opengl
+ x11-libs/libXrender:=
+ )
+"
+DEPEND="${RDEPEND}
+ media-libs/glm
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DSLOP_OPENGL=$(usex opengl)
+ )
+ cmake_src_configure
+}
diff --git a/x11-misc/slop/slop-9999.ebuild b/x11-misc/slop/slop-9999.ebuild
index afc048826632..a9c376b256ec 100644
--- a/x11-misc/slop/slop-9999.ebuild
+++ b/x11-misc/slop/slop-9999.ebuild
@@ -26,9 +26,11 @@ RDEPEND="
x11-libs/libXext
opengl? (
media-libs/glew:0=
+ media-libs/libglvnd
virtual/opengl
x11-libs/libXrender:=
- )"
+ )
+"
DEPEND="${RDEPEND}
media-libs/glm
"