summaryrefslogtreecommitdiff
path: root/x11-misc/slop
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-01 20:42:22 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-01 20:42:22 +0000
commit721254b86a09bdedd5eefd0de7899c90ea2ead1a (patch)
tree895fca7b3bd570d8df743dd518a6f36deca1a241 /x11-misc/slop
parent618c3037024b4e5328531cdc07c6ceb7486f5329 (diff)
gentoo resync : 01.01.2018
Diffstat (limited to 'x11-misc/slop')
-rw-r--r--x11-misc/slop/Manifest1
-rw-r--r--x11-misc/slop/slop-9999.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/x11-misc/slop/Manifest b/x11-misc/slop/Manifest
index b8bcd40cfe88..48a4a899e499 100644
--- a/x11-misc/slop/Manifest
+++ b/x11-misc/slop/Manifest
@@ -1,4 +1,5 @@
AUX slop-6.3.46-fix-build-system.patch 2274 BLAKE2B cec202a664d3329d7354f63d20e5a197363296d1506e46900ae51d542bc44279ac62fb9668dcaa2cbade49688d210f9fbac7cbbb706feb5382921536b8471c2b SHA512 344396f7cc8c60f09647c434b78183264dede5548e243df3408f46486f489eb14353fa770ba1f604f604a15417a92f84cd51c561b7026b74b854d8ba7d02cc67
DIST slop-6.3.46.tar.gz 89391 BLAKE2B 0150ca63e4a598e892abd5505e867f01204f29796dc378a7f3d0c041c1a27f000e98962c41cbf8109573575b37449c1869f29f988c5d2046b504382b2a56779d SHA512 9f44bbb8e14e71a17858711d8da902cb9cf5dc65ed47284be15122f2d1793544deab7f0700517bd07e44613662bfbc7f0991f3d36dcf74af6f90de5fbbd79558
EBUILD slop-6.3.46.ebuild 601 BLAKE2B 769a13a66a24a8067fdafbb6d3cce48090d4193fb40a14a98cd56d1d4d331e642ec50e601b8944e7276037e07cd52b27c0cb0b79295820c1305f63c8601f3051 SHA512 e96b0e0d8f2562f40a8770980dd46b0f7bbce5588b4fb1cb7d62c88a10fa9ae5880d40918db178f5f4ac5ce6c46957a685af528f795009c8094375738308fce4
+EBUILD slop-9999.ebuild 798 BLAKE2B fdb4c2671b9ab455c03293202c83ecdbb4e2f6dc44834116eb53f8cb76e66c6d8beed9a82be5c0067dcb2a2d4b540d3a22bb64fa692b969db7bf324ab644bac6 SHA512 7b47b74ffa960661790ead4795a3a8a8783bc13a18585fbf0255fa6775e98bb790ae5d4db3caaee78c2135a988d715183835e3f2154753c6b96727ad664b1bbe
MISC metadata.xml 630 BLAKE2B dbf7d848908c12d7104c7cd18cd2ca16114073803bd4600e10906a1fc4f86ddeb646359d26885551d998a279d1e11f0d74ad21b135e14a2bea827ef21ade15f7 SHA512 98eea5cce0e8a692076b5cb423a2f0522151d716ef0c9f346e915bfee8590d32dab59c183180ea7f87561bfb92e3840ad710f890a734640173bbcd471d779b0e
diff --git a/x11-misc/slop/slop-9999.ebuild b/x11-misc/slop/slop-9999.ebuild
new file mode 100644
index 000000000000..4aef7f894258
--- /dev/null
+++ b/x11-misc/slop/slop-9999.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils
+
+DESCRIPTION="An application that queries the user for a selection for printing"
+HOMEPAGE="https://github.com/naelstrof/slop"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/naelstrof/slop.git"
+else
+ SRC_URI="https://github.com/naelstrof/slop/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="opengl"
+
+RDEPEND="
+ dev-libs/icu:=
+ x11-libs/libX11
+ x11-libs/libXext
+ opengl? (
+ media-libs/glew:0=
+ virtual/opengl
+ x11-libs/libXrender:=
+ )"
+DEPEND="
+ ${RDEPEND}
+ media-libs/glm"
+
+src_configure() {
+ local mycmakeargs=(
+ -DSLOP_OPENGL=$(usex opengl)
+ )
+ cmake-utils_src_configure
+}