summaryrefslogtreecommitdiff
path: root/x11-misc/set_opacity/set_opacity-1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/set_opacity/set_opacity-1.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/set_opacity/set_opacity-1.0.ebuild')
-rw-r--r--x11-misc/set_opacity/set_opacity-1.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-misc/set_opacity/set_opacity-1.0.ebuild b/x11-misc/set_opacity/set_opacity-1.0.ebuild
new file mode 100644
index 000000000000..6f014ba2556d
--- /dev/null
+++ b/x11-misc/set_opacity/set_opacity-1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="Tool for set real compositing for windows through window's id, process' pid etc."
+HOMEPAGE="https://github.com/XVilka/set_opacity"
+SRC_URI="https://github.com/XVilka/set_opacity/archive-tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="x11-libs/libXdamage
+ x11-libs/libXcomposite
+ x11-libs/libXfixes
+ x11-libs/libXrender"
+RDEPEND=${DEPEND}
+
+S="${WORKDIR}/x11-tools-set_opacity"
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin set_opacity
+}