summaryrefslogtreecommitdiff
path: root/x11-misc/sent/sent-1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/sent/sent-1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/sent/sent-1.ebuild')
-rw-r--r--x11-misc/sent/sent-1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-misc/sent/sent-1.ebuild b/x11-misc/sent/sent-1.ebuild
new file mode 100644
index 000000000000..f8352a8d5281
--- /dev/null
+++ b/x11-misc/sent/sent-1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit savedconfig toolchain-funcs
+
+DESCRIPTION="Simple plaintext presentation tool"
+HOMEPAGE="https://tools.suckless.org/sent/"
+SRC_URI="https://dl.suckless.org/tools/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="
+ media-libs/fontconfig
+ x11-libs/libX11
+ x11-libs/libXft
+"
+RDEPEND="
+ ${DEPEND}
+ !savedconfig? ( media-gfx/farbfeld )
+"
+S=${WORKDIR}
+
+src_prepare() {
+ default
+
+ sed -i \
+ -e 's|^ @| |g' \
+ -e 's|@${CC}|$(CC)|g' \
+ -e '/^ echo/d' \
+ Makefile || die
+
+ restore_config config.def.h
+}
+
+src_compile() {
+ emake CC=$(tc-getCC)
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="/usr" install
+}