summaryrefslogtreecommitdiff
path: root/x11-misc/sct/sct-0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/sct/sct-0.4.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/sct/sct-0.4.ebuild')
-rw-r--r--x11-misc/sct/sct-0.4.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/x11-misc/sct/sct-0.4.ebuild b/x11-misc/sct/sct-0.4.ebuild
new file mode 100644
index 000000000000..f7784edbf7b8
--- /dev/null
+++ b/x11-misc/sct/sct-0.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Set color temperature of the screen"
+HOMEPAGE="https://www.umaxx.net/"
+SRC_URI="https://www.umaxx.net/dl/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="x11-libs/libXrandr"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ sed \
+ -e 's:_BSD_SOURCE:_DEFAULT_SOURCE:g' \
+ -i Makefile || die
+}
+
+src_install() {
+ dobin "${PN}"
+ doman "${PN}.1"
+ einstalldocs
+}