summaryrefslogtreecommitdiff
path: root/x11-misc/screenkey/screenkey-1.3-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /x11-misc/screenkey/screenkey-1.3-r1.ebuild
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'x11-misc/screenkey/screenkey-1.3-r1.ebuild')
-rw-r--r--x11-misc/screenkey/screenkey-1.3-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/x11-misc/screenkey/screenkey-1.3-r1.ebuild b/x11-misc/screenkey/screenkey-1.3-r1.ebuild
new file mode 100644
index 000000000000..e54264430a88
--- /dev/null
+++ b/x11-misc/screenkey/screenkey-1.3-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+
+inherit distutils-r1 xdg
+
+DESCRIPTION="A screencast tool to display your keys inspired by Screenflick"
+HOMEPAGE="https://www.thregr.org/~wavexx/software/screenkey/"
+
+if [[ "${PV}" == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/screenkey/${PN}.git"
+else
+ SRC_URI="https://gitlab.com/screenkey/${PN}/-/archive/v${PV}/${PN}-v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+ S="${WORKDIR}/${PN}-v${PV}"
+fi
+
+RESTRICT="test"
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="appindicator"
+
+BDEPEND="
+ dev-python/python-distutils-extra[${PYTHON_USEDEP}]
+ sys-devel/gettext
+"
+RDEPEND="
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ media-fonts/fontawesome
+ x11-libs/gtk+:3[X,introspection]
+ x11-misc/slop
+ appindicator? ( dev-libs/libappindicator:3[introspection] )
+"
+
+src_prepare() {
+ # Change the doc install path
+ sed -i "s|share/doc/screenkey|share/doc/${PF}|g" setup.py || die
+
+ default
+}