summaryrefslogtreecommitdiff
path: root/x11-misc/safeeyes
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-29 00:32:16 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-29 00:32:16 +0000
commitad108e7b751d67723534624b94eb0e04250dd1af (patch)
treeb2c2e47b9c23ac5a70d7170b3ba364b32da31944 /x11-misc/safeeyes
parentc44ae5c03130467400468d0e9a7f83e723c99f35 (diff)
gentoo auto-resync : 29:03:2025 - 00:32:15
Diffstat (limited to 'x11-misc/safeeyes')
-rw-r--r--x11-misc/safeeyes/Manifest1
-rw-r--r--x11-misc/safeeyes/safeeyes-2.2.3-r1.ebuild60
2 files changed, 61 insertions, 0 deletions
diff --git a/x11-misc/safeeyes/Manifest b/x11-misc/safeeyes/Manifest
index c9801b3888ad..1a57418bf461 100644
--- a/x11-misc/safeeyes/Manifest
+++ b/x11-misc/safeeyes/Manifest
@@ -1,5 +1,6 @@
DIST safeeyes-2.2.2.tar.gz 312701 BLAKE2B 73e316c699bb1b6a1291bc2afefc228067d692352788cbd68904917bbea8d8d566e3a3b764d44cb8be37d75a89a97326f153be98b69b800c42f49b0e9668dfd5 SHA512 b84f3bdeae06bc0db88a7ef1c029f8896880bd4f0cdf624eb332eb974dbfca4ce766f13d41b275747098016b3b3dbe4f1fe4ac544448916a641913ddf0a18f77
DIST safeeyes-2.2.3.tar.gz 319259 BLAKE2B 70eea85d1427bcde826890db770723564f601a6a7dfc04aee02d72fa43f1ed0e27acbef055f2acf27050a390cf079a817e978b5321982d9de172d39669c95f57 SHA512 4ecdf27527b81454c0f6f20c534634d7ed8f15c3903c1a39acf98eb97064ce33b6b7bb77ffa98e49520698335e9680130b701e215382565fca12f2608b71cd6f
EBUILD safeeyes-2.2.2.ebuild 1464 BLAKE2B 8073602eb3a6a9e18c1a6df2dfb5efcee7dff2fa0ba4a8d79de3202d3896c5a347a3589d3ba81722cac83d3887d02701401a0de8f7f1b2f7e2c54c1b6cc50c8e SHA512 297deb404664f3a1e1a44b59e4f110803bf794b0b4ae0cfe4a7e7877a5a801d31d5124e2081d26c67e6b33fc534a0ccca1626f986722f3adda64283d2db06da9
+EBUILD safeeyes-2.2.3-r1.ebuild 1464 BLAKE2B e52d3b39551e3277979e114a9643fbb546098748f7ec0b93af43fcb1a522cac5ade35f90f39e18bd62b5269faafb3280d4403418e48192bca25b6ed2d399eeb0 SHA512 7d26b9abef2aeb5e7bca699b6c4d16a626b05e4cb6fca18d36491f7c557f2110d3b62d30d415d8e61a17f1a2fdaf8935f0a46660ad441af13b9a07478b967b5e
EBUILD safeeyes-2.2.3.ebuild 1464 BLAKE2B 8073602eb3a6a9e18c1a6df2dfb5efcee7dff2fa0ba4a8d79de3202d3896c5a347a3589d3ba81722cac83d3887d02701401a0de8f7f1b2f7e2c54c1b6cc50c8e SHA512 297deb404664f3a1e1a44b59e4f110803bf794b0b4ae0cfe4a7e7877a5a801d31d5124e2081d26c67e6b33fc534a0ccca1626f986722f3adda64283d2db06da9
MISC metadata.xml 347 BLAKE2B eda163f3ff13421872558f176120fc2fa5488afa1c9e2b2bd1c3aae6bf76e4e73758f35ba2af529beaf73d5677970ffe6319e8db22279c5eb7885f9f135e9243 SHA512 c09ce25d4d00dc7d322ab1505feb17b0bdec7aa1ec9e4a847705889ec38b76b03758d0a9bf1fc01fd6131d278850ae38462256ab8c968f183523e48dc2692aca
diff --git a/x11-misc/safeeyes/safeeyes-2.2.3-r1.ebuild b/x11-misc/safeeyes/safeeyes-2.2.3-r1.ebuild
new file mode 100644
index 000000000000..a035491c1d29
--- /dev/null
+++ b/x11-misc/safeeyes/safeeyes-2.2.3-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+PYTHON_REQ_USE="tk" # for site-packages/Xlib/ext/randr.py
+DISTUTILS_USE_PEP517=setuptools
+
+inherit xdg distutils-r1 pypi
+
+DESCRIPTION="Linux alternative to EyeLeo"
+HOMEPAGE="https://github.com/slgobinath/SafeEyes"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ dev-libs/libayatana-appindicator
+ dev-python/babel[${PYTHON_USEDEP}]
+ dev-python/croniter[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/python-xlib[${PYTHON_USEDEP}]
+ media-sound/alsa-utils
+ x11-apps/xprop
+ x11-libs/gtk+:3[introspection]
+ x11-libs/libnotify[introspection]
+ x11-misc/xprintidle
+ "
+
+python_install() {
+ distutils-r1_python_install
+
+ # Workaround for https://bugs.gentoo.org/926816
+ # Files were misplaced and also duplicate across Python slots.
+ local misplaced_usr="${D}/usr/lib/${EPYTHON}/site-packages/usr"
+ local i
+ for i in applications icons ; do
+ local source="${misplaced_usr}/share/${i}"
+ local target="${D}/usr/share/${i}"
+ if [[ ! -d "${target}" ]]; then
+ dodir /usr/share/
+ mv "${source}" "${target}" || die
+ fi
+ done
+ rm -R "${misplaced_usr}" || die
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}