summaryrefslogtreecommitdiff
path: root/x11-misc/redshift
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-29 00:32:16 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-29 00:32:16 +0000
commitad108e7b751d67723534624b94eb0e04250dd1af (patch)
treeb2c2e47b9c23ac5a70d7170b3ba364b32da31944 /x11-misc/redshift
parentc44ae5c03130467400468d0e9a7f83e723c99f35 (diff)
gentoo auto-resync : 29:03:2025 - 00:32:15
Diffstat (limited to 'x11-misc/redshift')
-rw-r--r--x11-misc/redshift/Manifest1
-rw-r--r--x11-misc/redshift/redshift-1.12-r13.ebuild102
2 files changed, 103 insertions, 0 deletions
diff --git a/x11-misc/redshift/Manifest b/x11-misc/redshift/Manifest
index 978049bd347b..a7cb72a8ad3b 100644
--- a/x11-misc/redshift/Manifest
+++ b/x11-misc/redshift/Manifest
@@ -3,4 +3,5 @@ AUX redshift-1.12-libayatana-appindicator.patch 1125 BLAKE2B 94eac1a5b7567788d1b
DIST redshift-1.12.tar.xz 486072 BLAKE2B b7ce74ae134a8f6954ff978e99670f24c447b23ab5e8d69a62109806bfe38c5e1b41e5f65cd6b182298aaf3e0b9187a2c70ea3148fd4ccba8b9c17697024944d SHA512 225e222e5f2c55be4571094ccaf02a92e162dfc35fd0fe504084e21e358b888a72f9992f9f9edaf1d496eb673af74a0d825ae5cf6ef7f0f1ab51d32419722c32
EBUILD redshift-1.12-r10.ebuild 2128 BLAKE2B ec37f17b3f2c2e50c3fb7e48d97c9a5fc745369ff489e48128fa18f9cf61e35ab270b6f0465b3da4085da449bc7b8c4c5e23d4e1273539b4aff0b634db0951df SHA512 070bf94d1adc69d87e0ba56f41a208080a3552a6999864806d8360d17451cd100f242e35865928064abaf2c4855237a5dd1aebdcc0d963e396940a3a3ccb4c1c
EBUILD redshift-1.12-r12.ebuild 2360 BLAKE2B d7b08ad24290d09f46b828e33564bc792f4aed763cae2ebd5fe2f640931389a6cde413893c87f591c141541a7d0e778fa730d29ca8f8e0e97877b7a669caf7c5 SHA512 f235e01df063b2f616a7fbbd528ae7f9509acef34804925a6babac1f08cba5a020297e6b798bdb494524e3ceca4b241ca57ebd155b6ecaa9c07643cf6507e8c6
+EBUILD redshift-1.12-r13.ebuild 2364 BLAKE2B 1c5611663949595a98b0ef7ce3081212695d9a1e54095b5941a7f213135c07fb7eaab71593dc16e9056c64ebda66cf6a36beed7074f433fafc3c0c209206aab2 SHA512 433efae7b119fb0c24b27fe0edf2571439a452585b33187892a114c77abb46b739270e27d2a3f53062a30248fa60b2945226d2cc432168c92ddf17d2c4f29ed9
MISC metadata.xml 403 BLAKE2B 10a0e5faa2716a1caa6882d1e9cb58e2a76c7ed7e75713347e89097b212753dc0a21e3562e5d09fafdd25177a385a9447fc0fb2a250368e22796072cc1b72158 SHA512 c7a329c809a328c06628b5062891cd444f95cbad62ccbb3c2c9ae70a0b4b477e5406c7d3729393f6342312025b854f5cc171a25d1564e2b4f05f7823f4719bfe
diff --git a/x11-misc/redshift/redshift-1.12-r13.ebuild b/x11-misc/redshift/redshift-1.12-r13.ebuild
new file mode 100644
index 000000000000..7a3a84886e97
--- /dev/null
+++ b/x11-misc/redshift/redshift-1.12-r13.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..13} )
+
+inherit autotools flag-o-matic systemd xdg-utils python-r1
+
+DESCRIPTION="A screen color temperature adjusting software"
+HOMEPAGE="http://jonls.dk/redshift/"
+SRC_URI="https://github.com/jonls/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="appindicator geoclue gtk nls"
+
+COMMON_DEPEND=">=x11-libs/libX11-1.4
+ x11-libs/libXxf86vm
+ x11-libs/libxcb
+ x11-libs/libdrm
+ appindicator? ( dev-libs/libayatana-appindicator )
+ geoclue? ( app-misc/geoclue:2.0 dev-libs/glib:2 )
+ gtk? ( ${PYTHON_DEPS} )"
+RDEPEND="${COMMON_DEPEND}
+ gtk? ( dev-python/pygobject[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ dev-python/pyxdg[${PYTHON_USEDEP}] )"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.50
+ nls? ( sys-devel/gettext )
+"
+REQUIRED_USE="gtk? ( ${PYTHON_REQUIRED_USE} )"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-apparmor.patch
+ "${FILESDIR}"/${P}-libayatana-appindicator.patch
+)
+
+src_prepare() {
+ default
+
+ # we need to re-generate file py-compile with a version
+ # that supports Python >=3.12 to not fail with error:
+ # ModuleNotFoundError: No module named 'imp'
+ rm py-compile || die
+ eautoreconf
+}
+
+src_configure() {
+ use gtk && python_setup
+
+ # Fix compile for Clang (bug #732438)
+ append-cflags -fPIE
+
+ econf \
+ $(use_enable nls) \
+ --enable-drm \
+ --enable-randr \
+ --enable-vidmode \
+ --disable-wingdi \
+ \
+ --disable-corelocation \
+ $(use_enable geoclue geoclue2) \
+ \
+ $(use_enable gtk gui) \
+ --with-systemduserunitdir="$(systemd_get_userunitdir)" \
+ --enable-apparmor \
+ --disable-quartz \
+ --disable-ubuntu
+}
+
+_impl_specific_src_install() {
+ emake DESTDIR="${D}" \
+ PYTHON="${PYTHON}" \
+ pythondir="$(python_get_sitedir)" \
+ -C src/redshift-gtk install
+}
+
+src_install() {
+ emake DESTDIR="${D}" UPDATE_ICON_CACHE=/bin/true install
+
+ if use gtk; then
+ python_foreach_impl _impl_specific_src_install
+ python_replicate_script "${D}"/usr/bin/redshift-gtk
+ dosym redshift-gtk /usr/bin/gtk-redshift
+
+ python_foreach_impl python_optimize
+
+ # https://bugs.gentoo.org/784281
+ mv "${D}"/usr/share/{appdata,metainfo}/ || die
+ fi
+}
+
+pkg_postinst() {
+ use gtk && xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ use gtk && xdg_icon_cache_update
+}