summaryrefslogtreecommitdiff
path: root/x11-misc/redshift
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-19 13:58:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-19 13:58:24 +0100
commit12652841746da7ae2f03b8b0c571a9bd5033e15c (patch)
tree17ba3a2b3f142284453d0e9109be1765200f643b /x11-misc/redshift
parent27f7ac2204449d9fc2137f442522b4fb10327d90 (diff)
gentoo auto-resync : 19:10:2022 - 13:58:24
Diffstat (limited to 'x11-misc/redshift')
-rw-r--r--x11-misc/redshift/Manifest2
-rw-r--r--x11-misc/redshift/redshift-1.12-r7.ebuild85
2 files changed, 87 insertions, 0 deletions
diff --git a/x11-misc/redshift/Manifest b/x11-misc/redshift/Manifest
index 9942e8cb50eb..04c6b4a6e708 100644
--- a/x11-misc/redshift/Manifest
+++ b/x11-misc/redshift/Manifest
@@ -1,3 +1,5 @@
DIST redshift-1.12.tar.gz 659019 BLAKE2B 09339a57fee192e3428ba4387cbea498f2f9f97eb75a418588cdda3289cfa7b7fada4cb299e983e9e6d2ffe3822c8235082e67bdfa542716b6dee9fc853a8dc1 SHA512 6763f6964b577fc146191af1c67a283a60df5bbdd3a74bfc94f66d5f9f3bef8835a479c6ec8a648b650b83a0e245928884a0f628606ace8c3f58d8319d35036f
+DIST redshift-1.12.tar.xz 486072 BLAKE2B b7ce74ae134a8f6954ff978e99670f24c447b23ab5e8d69a62109806bfe38c5e1b41e5f65cd6b182298aaf3e0b9187a2c70ea3148fd4ccba8b9c17697024944d SHA512 225e222e5f2c55be4571094ccaf02a92e162dfc35fd0fe504084e21e358b888a72f9992f9f9edaf1d496eb673af74a0d825ae5cf6ef7f0f1ab51d32419722c32
EBUILD redshift-1.12-r6.ebuild 2068 BLAKE2B b41852d9f1f2c7ecf9aefefb639a6015f59359cda19a8de920cce72def7df0d2911c81acd48978b5ae48108aad4e08af203a5cc912c39bbc3cb471855d5d7872 SHA512 6018aa1673c9cb12c0e99892b0f1f1c04eb12b22172ac83d187620f6fe8dcc558f42d3292a35bccbe799ab1669d27b0a9b3cd394e8b7942d27f5a6932e7882bc
+EBUILD redshift-1.12-r7.ebuild 2017 BLAKE2B 8f02639d4f575e2ef19df39859bec90d3ac4938cd704dd7b08bd4afe7c5599295ea5002bd39762b24c92dfad15bfde703bcf0c7554862704fb1bbdf0f412faa2 SHA512 2153568f472b8264ebab11c042386d270d812808f4e54df6f048c5fb29e33338ad7dfb2e706bf049bc7ace718a89bbb9844714c88de454ba4b1a2ac3d88ee416
MISC metadata.xml 522 BLAKE2B db9be8da0b96a5f7d742baadda739df011a5f055a944d41b67b3ba3137b7e92acead9b0afd72410a4c4f203fedf300f49a052c809577351b3b107f447dbf4c6b SHA512 c5732a20ce965daea3c663ba00d2fd9ea484cade35c22011a9e4f051ce202a0da560c428c8775b5eefaa726c92f6f31014cc47780b4ba329db81c1dd7defbbbc
diff --git a/x11-misc/redshift/redshift-1.12-r7.ebuild b/x11-misc/redshift/redshift-1.12-r7.ebuild
new file mode 100644
index 000000000000..3fd13868f5ba
--- /dev/null
+++ b/x11-misc/redshift/redshift-1.12-r7.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit flag-o-matic systemd xdg-utils python-r1
+
+DESCRIPTION="A screen color temperature adjusting software"
+HOMEPAGE="http://jonls.dk/redshift/"
+SRC_URI="https://github.com/jonls/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+IUSE="appindicator geoclue gtk nls"
+
+COMMON_DEPEND=">=x11-libs/libX11-1.4
+ x11-libs/libXxf86vm
+ x11-libs/libxcb
+ x11-libs/libdrm
+ appindicator? ( dev-libs/libappindicator:3[introspection] )
+ geoclue? ( app-misc/geoclue:2.0 dev-libs/glib:2 )
+ gtk? ( ${PYTHON_DEPS} )"
+RDEPEND="${COMMON_DEPEND}
+ gtk? ( dev-python/pygobject[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ dev-python/pyxdg[${PYTHON_USEDEP}] )"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.50
+ nls? ( sys-devel/gettext )
+"
+REQUIRED_USE="gtk? ( ${PYTHON_REQUIRED_USE} )"
+
+src_configure() {
+ use gtk && python_setup
+
+ # Fix compile for Clang (bug #732438)
+ append-cflags -fPIE
+
+ econf \
+ $(use_enable nls) \
+ --enable-drm \
+ --enable-randr \
+ --enable-vidmode \
+ --disable-wingdi \
+ \
+ --disable-corelocation \
+ $(use_enable geoclue geoclue2) \
+ \
+ $(use_enable gtk gui) \
+ --with-systemduserunitdir="$(systemd_get_userunitdir)" \
+ --enable-apparmor \
+ --disable-quartz \
+ --disable-ubuntu
+}
+
+_impl_specific_src_install() {
+ emake DESTDIR="${D}" pythondir="$(python_get_sitedir)" \
+ -C src/redshift-gtk install
+}
+
+src_install() {
+ emake DESTDIR="${D}" UPDATE_ICON_CACHE=/bin/true install
+
+ if use gtk; then
+ python_foreach_impl _impl_specific_src_install
+ python_replicate_script "${D}"/usr/bin/redshift-gtk
+ dosym redshift-gtk /usr/bin/gtk-redshift
+
+ python_foreach_impl python_optimize
+
+ # https://bugs.gentoo.org/784281
+ mv "${D}"/usr/share/{appdata,metainfo}/ || die
+ fi
+}
+
+pkg_postinst() {
+ use gtk && xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ use gtk && xdg_icon_cache_update
+}