summaryrefslogtreecommitdiff
path: root/x11-misc/redshift
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /x11-misc/redshift
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'x11-misc/redshift')
-rw-r--r--x11-misc/redshift/Manifest1
-rw-r--r--x11-misc/redshift/redshift-1.12-r6.ebuild90
2 files changed, 91 insertions, 0 deletions
diff --git a/x11-misc/redshift/Manifest b/x11-misc/redshift/Manifest
index a0e9d39eb635..ce96fb992edc 100644
--- a/x11-misc/redshift/Manifest
+++ b/x11-misc/redshift/Manifest
@@ -2,4 +2,5 @@ DIST redshift-1.12.tar.gz 659019 BLAKE2B 09339a57fee192e3428ba4387cbea498f2f9f97
EBUILD redshift-1.12-r3.ebuild 1955 BLAKE2B 9d6cbed8b116f5173c284fa6a58bb616ff00ac9af35c15945bf0615b2aeb90ee8084bb240e6a9ebe8c5cb79f846c58aeae35ed86cfd9bc7a3130f6ff3a437a9c SHA512 01007093bc7e4a841bb3eb66975c51d6f4e2a1b5ad664acf1885d26aa4914d8d4633f10e2d8cb051b1ebd07add545db4fa817d409b6761b6903d7c87af43f487
EBUILD redshift-1.12-r4.ebuild 2032 BLAKE2B 6b3d47a74a0a93c8086b1db87a561467bcd238dd7af2e5551ce1576fb9e8758966694584590211ac377051b6b64c21f3221996a880902553b81cb7b3fa51c0d6 SHA512 b63ea2755fed84e4d5612ba13a36812e4b13b313cffbfa4a023a90158a9c6a04f009c0d70804380481b1fce805ce9809fc0a809f24fcff90245e6bd6de3f2d51
EBUILD redshift-1.12-r5.ebuild 2120 BLAKE2B 4b91aa73653fe5d2ac649e6a5a42d41c2e7e000d93a17b5b258dcff858714498bc552c2460f76dce8c8babedfac880dfe4ae88278f525ef0cfaa8e3f9c3f5c6b SHA512 3ab83b5e769d8f89b86b898f7f1c71435da91a9927fb2b2ac3664a2a9e2a7f613ef1c5a7306e0ee27a749b495d166dadf82d46d7ee216ff87d69bab6c23dfb6f
+EBUILD redshift-1.12-r6.ebuild 2068 BLAKE2B b41852d9f1f2c7ecf9aefefb639a6015f59359cda19a8de920cce72def7df0d2911c81acd48978b5ae48108aad4e08af203a5cc912c39bbc3cb471855d5d7872 SHA512 6018aa1673c9cb12c0e99892b0f1f1c04eb12b22172ac83d187620f6fe8dcc558f42d3292a35bccbe799ab1669d27b0a9b3cd394e8b7942d27f5a6932e7882bc
MISC metadata.xml 522 BLAKE2B db9be8da0b96a5f7d742baadda739df011a5f055a944d41b67b3ba3137b7e92acead9b0afd72410a4c4f203fedf300f49a052c809577351b3b107f447dbf4c6b SHA512 c5732a20ce965daea3c663ba00d2fd9ea484cade35c22011a9e4f051ce202a0da560c428c8775b5eefaa726c92f6f31014cc47780b4ba329db81c1dd7defbbbc
diff --git a/x11-misc/redshift/redshift-1.12-r6.ebuild b/x11-misc/redshift/redshift-1.12-r6.ebuild
new file mode 100644
index 000000000000..997257dbf0c1
--- /dev/null
+++ b/x11-misc/redshift/redshift-1.12-r6.ebuild
@@ -0,0 +1,90 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit flag-o-matic systemd autotools xdg-utils python-r1
+
+DESCRIPTION="A screen color temperature adjusting software"
+HOMEPAGE="http://jonls.dk/redshift/"
+SRC_URI="https://github.com/jonls/redshift/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 arm64 ~ppc64 ~riscv x86"
+IUSE="appindicator geoclue gtk nls"
+
+COMMON_DEPEND=">=x11-libs/libX11-1.4
+ x11-libs/libXxf86vm
+ x11-libs/libxcb
+ x11-libs/libdrm
+ appindicator? ( dev-libs/libappindicator:3[introspection] )
+ geoclue? ( app-misc/geoclue:2.0 dev-libs/glib:2 )
+ gtk? ( ${PYTHON_DEPS} )"
+RDEPEND="${COMMON_DEPEND}
+ gtk? ( dev-python/pygobject[${PYTHON_USEDEP}]
+ x11-libs/gtk+:3[introspection]
+ dev-python/pyxdg[${PYTHON_USEDEP}] )"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.50
+ nls? ( sys-devel/gettext )
+"
+REQUIRED_USE="gtk? ( ${PYTHON_REQUIRED_USE} )"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ use gtk && python_setup
+
+ # Fix compile for Clang (bug #732438)
+ append-cflags -fPIE
+
+ econf \
+ $(use_enable nls) \
+ --enable-drm \
+ --enable-randr \
+ --enable-vidmode \
+ --disable-wingdi \
+ \
+ --disable-corelocation \
+ $(use_enable geoclue geoclue2) \
+ \
+ $(use_enable gtk gui) \
+ --with-systemduserunitdir="$(systemd_get_userunitdir)" \
+ --enable-apparmor \
+ --disable-quartz \
+ --disable-ubuntu
+}
+
+_impl_specific_src_install() {
+ emake DESTDIR="${D}" pythondir="$(python_get_sitedir)" \
+ -C src/redshift-gtk install
+}
+
+src_install() {
+ emake DESTDIR="${D}" UPDATE_ICON_CACHE=/bin/true install
+
+ if use gtk; then
+ python_foreach_impl _impl_specific_src_install
+ python_replicate_script "${D}"/usr/bin/redshift-gtk
+ dosym redshift-gtk /usr/bin/gtk-redshift
+
+ python_foreach_impl python_optimize
+
+ # https://bugs.gentoo.org/784281
+ mv "${D}"/usr/share/{appdata,metainfo}/ || die
+ fi
+}
+
+pkg_postinst() {
+ use gtk && xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ use gtk && xdg_icon_cache_update
+}