summaryrefslogtreecommitdiff
path: root/x11-misc/read-edid/read-edid-3.0.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/read-edid/read-edid-3.0.2.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/read-edid/read-edid-3.0.2.ebuild')
-rw-r--r--x11-misc/read-edid/read-edid-3.0.2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/x11-misc/read-edid/read-edid-3.0.2.ebuild b/x11-misc/read-edid/read-edid-3.0.2.ebuild
new file mode 100644
index 000000000000..7c9d0bb7c563
--- /dev/null
+++ b/x11-misc/read-edid/read-edid-3.0.2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit cmake-utils
+
+DESCRIPTION="Program that can get information from a PnP monitor"
+HOMEPAGE="http://www.polypux.org/projects/read-edid/"
+SRC_URI="http://www.polypux.org/projects/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="-* amd64 x86"
+
+DEPEND=">=dev-libs/libx86-1.1"
+RDEPEND="$DEPEND"
+
+src_prepare() {
+ sed -i -e 's|COPYING||g;s|share/doc/read-edid|&-'"${PV}"'|g' \
+ CMakeLists.txt || die
+ cmake-utils_src_prepare
+}