summaryrefslogtreecommitdiff
path: root/x11-misc/py3status/py3status-3.38.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-03 22:39:47 +0100
commit7f0ccc917c7abe6223784c703d86cd14755691fb (patch)
tree8c6793f68896b341e22f33d7e6cef88e481f4a8b /x11-misc/py3status/py3status-3.38.ebuild
parent9aa80713372911cec499b3adb2cd746790920916 (diff)
gentoo resync : 03.07.2021
Diffstat (limited to 'x11-misc/py3status/py3status-3.38.ebuild')
-rw-r--r--x11-misc/py3status/py3status-3.38.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/x11-misc/py3status/py3status-3.38.ebuild b/x11-misc/py3status/py3status-3.38.ebuild
new file mode 100644
index 000000000000..249cd9474c6a
--- /dev/null
+++ b/x11-misc/py3status/py3status-3.38.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{3_7,3_8,3_9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+SRC_URI="https://github.com/ultrabug/py3status/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+inherit distutils-r1
+
+MY_PN="py3status"
+MY_P="${MY_PN}-${PV/_/-}"
+
+DESCRIPTION="py3status is an extensible i3status wrapper written in python"
+HOMEPAGE="https://github.com/ultrabug/py3status"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gevent minimal +udev"
+
+RDEPEND="
+ !minimal? ( x11-misc/i3status )
+ gevent? ( >=dev-python/gevent-1.2.0[${PYTHON_USEDEP}] )
+ udev? ( >=dev-python/pyudev-0.21.0[${PYTHON_USEDEP}] )
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S=${WORKDIR}/${MY_P}