summaryrefslogtreecommitdiff
path: root/x11-misc/projecteur/projecteur-0.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /x11-misc/projecteur/projecteur-0.6.ebuild
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'x11-misc/projecteur/projecteur-0.6.ebuild')
-rw-r--r--x11-misc/projecteur/projecteur-0.6.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/x11-misc/projecteur/projecteur-0.6.ebuild b/x11-misc/projecteur/projecteur-0.6.ebuild
new file mode 100644
index 000000000000..2891b3b14b88
--- /dev/null
+++ b/x11-misc/projecteur/projecteur-0.6.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN/p/P}"
+
+inherit cmake-utils udev xdg-utils
+
+DESCRIPTION="Linux Desktop Application for the Logitech Spotlight device"
+HOMEPAGE="https://github.com/jahnf/Projecteur"
+SRC_URI="https://github.com/jahnf/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5[xcb]
+ dev-qt/qtnetwork:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ virtual/udev
+ x11-libs/libX11
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="virtual/pkgconfig"
+
+pkg_postinst() {
+ udev_reload
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ udev_reload
+ xdg_icon_cache_update
+}