summaryrefslogtreecommitdiff
path: root/x11-misc/polybar/polybar-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
commit2018227e9344edb9da15fc6a4a8298086cc2aa77 (patch)
treec18e1c09e605e94e2a1e93345ad25746cc9e14b9 /x11-misc/polybar/polybar-9999.ebuild
parent6f8038813c460b4f0572d5ef595cdfa94af3a94d (diff)
gentoo resync : 02.06.2019
Diffstat (limited to 'x11-misc/polybar/polybar-9999.ebuild')
-rw-r--r--x11-misc/polybar/polybar-9999.ebuild39
1 files changed, 32 insertions, 7 deletions
diff --git a/x11-misc/polybar/polybar-9999.ebuild b/x11-misc/polybar/polybar-9999.ebuild
index 3d18bd3871c8..70e8d426aaf5 100644
--- a/x11-misc/polybar/polybar-9999.ebuild
+++ b/x11-misc/polybar/polybar-9999.ebuild
@@ -1,19 +1,29 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python2_7 )
+EAPI=7
-inherit cmake-utils git-r3 python-single-r1
+PYTHON_COMPAT=( python2_7 )
+inherit cmake-utils python-single-r1
DESCRIPTION="A fast and easy-to-use tool for creating status bars"
HOMEPAGE="https://github.com/jaagr/polybar"
-EGIT_REPO_URI="https://github.com/jaagr/${PN}.git"
-EGIT_CLONE_TYPE="shallow"
+
+if [[ ${PV} != *9999* ]]; then
+ XPP_VERSION="1.4.0"
+ I3IPCPP_VERSION="0.7.1"
+ SRC_URI="https://github.com/jaagr/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/jaagr/xpp/archive/${XPP_VERSION}.tar.gz -> xpp-${XPP_VERSION}.tar.gz
+ https://github.com/jaagr/i3ipcpp/archive/v${I3IPCPP_VERSION}.tar.gz -> i3ipcpp-${I3IPCPP_VERSION}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+else
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/jaagr/${PN}.git"
+ EGIT_CLONE_TYPE="shallow"
+fi
LICENSE="MIT"
SLOT="0"
-KEYWORDS=""
IUSE="alsa curl i3wm ipc mpd network pulseaudio"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
@@ -36,6 +46,20 @@ DEPEND="
RDEPEND="${DEPEND}"
+src_prepare() {
+ cmake-utils_src_prepare
+
+ if [[ ${PV} != *9999* ]]; then
+ rmdir "${S}"/lib/xpp || die
+ mv "${WORKDIR}"/xpp-$XPP_VERSION "${S}"/lib/xpp || die
+
+ rmdir "${S}"/lib/i3ipcpp || die
+ mv "${WORKDIR}"/i3ipcpp-$I3IPCPP_VERSION "${S}"/lib/i3ipcpp || die
+
+ sed -i "s/.*cpp_error,.*/&\n\t 'eventstruct' : lambda x, y: None,/" lib/xpp/generators/cpp_client.py || die "sed failed"
+ fi
+}
+
src_configure() {
local mycmakeargs=(
-DENABLE_ALSA="$(usex alsa)"
@@ -46,5 +70,6 @@ src_configure() {
-DENABLE_NETWORK="$(usex network)"
-DENABLE_PULSEAUDIO="$(usex pulseaudio)"
)
+
cmake-utils_src_configure
}