summaryrefslogtreecommitdiff
path: root/x11-misc/peksystray/peksystray-0.4.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-05 05:29:57 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-05 05:29:57 +0100
commit4e777c0133d093c9c8b992c92e0f244e2055bf71 (patch)
treed6fbeed2e9eb1b486babf5d6f4886da4bdba4dbc /x11-misc/peksystray/peksystray-0.4.0-r1.ebuild
parent6f57e716c7968def6387f9db258e883125bab84f (diff)
gentoo auto-resync : 05:05:2023 - 05:29:57
Diffstat (limited to 'x11-misc/peksystray/peksystray-0.4.0-r1.ebuild')
-rw-r--r--x11-misc/peksystray/peksystray-0.4.0-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-misc/peksystray/peksystray-0.4.0-r1.ebuild b/x11-misc/peksystray/peksystray-0.4.0-r1.ebuild
new file mode 100644
index 000000000000..ed1c981c805d
--- /dev/null
+++ b/x11-misc/peksystray/peksystray-0.4.0-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="System tray dockapp for window managers supporting docking"
+HOMEPAGE="https://peksystray.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~x86"
+
+DEPEND="x11-libs/libX11
+ x11-libs/libXt"
+
+PATCHES=( "${FILESDIR}/${P}-asneeded.patch" )
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ dobin src/peksystray
+ default
+}