summaryrefslogtreecommitdiff
path: root/x11-misc/pcmanfm-qt/pcmanfm-qt-0.17.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-05-22 07:31:18 +0100
commit908778078736bd36f7a60a2d576d415cb8e000fa (patch)
treec6a4796c48b608c14dc7e9674cdbd38f905e3c15 /x11-misc/pcmanfm-qt/pcmanfm-qt-0.17.0-r1.ebuild
parent185fa19bbf68a4d4dca534d2b46729207a177f16 (diff)
gentoo resync : 22.05.2021
Diffstat (limited to 'x11-misc/pcmanfm-qt/pcmanfm-qt-0.17.0-r1.ebuild')
-rw-r--r--x11-misc/pcmanfm-qt/pcmanfm-qt-0.17.0-r1.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/x11-misc/pcmanfm-qt/pcmanfm-qt-0.17.0-r1.ebuild b/x11-misc/pcmanfm-qt/pcmanfm-qt-0.17.0-r1.ebuild
new file mode 100644
index 000000000000..11ef42c99714
--- /dev/null
+++ b/x11-misc/pcmanfm-qt/pcmanfm-qt-0.17.0-r1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake optfeature xdg-utils
+
+DESCRIPTION="Qt GUI Tabbed Filemanager"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ "${PV}" == "9999" ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+LICENSE="GPL-2 GPL-2+ LGPL-2.1+"
+SLOT="0"
+
+BDEPEND="
+ dev-qt/linguist-tools:5
+ >=dev-util/lxqt-build-tools-0.9.0
+"
+DEPEND="
+ dev-libs/glib:2
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ sys-apps/util-linux
+ =x11-libs/libfm-qt-$(ver_cut 1-2)*
+ x11-libs/libxcb:=
+ x11-misc/xdg-utils
+ virtual/freedesktop-icon-theme
+"
+RDEPEND="${DEPEND}
+ >=lxde-base/lxmenu-data-0.1.5
+"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+
+ optfeature "mount password storing" gnome-base/gnome-keyring
+ ! has_version lxqt-base/lxqt-meta && optfeature "trash functionality" gnome-base/gvfs
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}