summaryrefslogtreecommitdiff
path: root/x11-misc/mygestures/mygestures-2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
commitc719fdcee603a5a706a45d10cb598762d56a727d (patch)
tree620cbf137661399a3fb1eff92914204f9a970713 /x11-misc/mygestures/mygestures-2.0.ebuild
parentcc4618c9ba3d974948ebf340b542d8cb01db2f55 (diff)
gentoo resync : 25.09.2021
Diffstat (limited to 'x11-misc/mygestures/mygestures-2.0.ebuild')
-rw-r--r--x11-misc/mygestures/mygestures-2.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/x11-misc/mygestures/mygestures-2.0.ebuild b/x11-misc/mygestures/mygestures-2.0.ebuild
new file mode 100644
index 000000000000..18b0d8fe375b
--- /dev/null
+++ b/x11-misc/mygestures/mygestures-2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Mouse gestures for X"
+HOMEPAGE="https://github.com/deters/mygestures"
+SRC_URI="https://github.com/deters/mygestures/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/libxml2
+ x11-libs/libX11
+ x11-libs/libXi
+ x11-libs/libXrender
+ x11-libs/libXtst"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_install() {
+ dobin src/mygestures #814482
+
+ dodoc README.md
+
+ insinto /etc
+ doins mygestures.xml
+}