summaryrefslogtreecommitdiff
path: root/x11-misc/mugshot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /x11-misc/mugshot
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'x11-misc/mugshot')
-rw-r--r--x11-misc/mugshot/Manifest3
-rw-r--r--x11-misc/mugshot/files/mugshot-0.4.2-python39.patch36
-rw-r--r--x11-misc/mugshot/mugshot-0.4.2-r1.ebuild4
3 files changed, 41 insertions, 2 deletions
diff --git a/x11-misc/mugshot/Manifest b/x11-misc/mugshot/Manifest
index 6a6e4d92d404..6a065482eb4d 100644
--- a/x11-misc/mugshot/Manifest
+++ b/x11-misc/mugshot/Manifest
@@ -1,3 +1,4 @@
+AUX mugshot-0.4.2-python39.patch 1369 BLAKE2B e006525dae248e4e8d04a01932f74371846c2757c085f5a0afc634f2c163c81918e6130ca796bcf122645bb7bd4e33348eea3ed0d926ff867028ab84641bf67a SHA512 c3868bec2772e7834bae8de87c2407986aacca1d32125631da92788ac9ae03e5a688b36ff6090792990f6c3163ecae1623eccd84349dc0099b4809258f14793b
DIST mugshot-0.4.2.tar.gz 121020 BLAKE2B c092e25273dbd8ef9cbfbc001fb5f86b134ed8f9bf5d84993d5f46664f17eb74eda5c121ee70b5f0c4b0adb5aa1fc4d21d8c59d3f0cf4a4f67991d06690f5aa5 SHA512 721629cf4a7e4d84fd8505279cf88c88ac88c7b6c995ac84a2fd6a9b978c92716bbe20d7b0301ca70e99c007698e4cddf41b6cf1111bf496eec4d39591cd9ed1
-EBUILD mugshot-0.4.2-r1.ebuild 1534 BLAKE2B 9ec842e924950051e7e65eea7c10afea40fe9802e69fad07098e78b76c179908e177fa1f7326b68813ea3f573892326f660b5899814b517a37629c547502dcfe SHA512 44934fa75f7554eac3a914742ce8d08003a8f17583dc7d2eb14cd66059d86bb3fc697ea60f95f50dbba8829154edb01586f5d53307d4f3bed560c9bff038267c
+EBUILD mugshot-0.4.2-r1.ebuild 1587 BLAKE2B 4c48a5849b55e9d6a21974bcb7c102ed6d6cc1b29685066e2aef2776931bcd3488b7c6a351b3a7dcec9bceb582e1fc688c5b919ae6db0f5f863d9fa832514fb1 SHA512 0b02356145d66c3d0e00a13db08756f1547050e98fa864b34e3c73ec2bbef7fd239a4f72d34864c4540970fb0ebd6fa8f0c774c6379268b3d7de4f370c704e69
MISC metadata.xml 943 BLAKE2B b39c09aa84b6a1f25d001e073b2c369af9ebebb7448fff5b3abc83898516963e117c33d1c03fb6db72422e4b20c065ed78e711326f28912e1ed5321b232bbee1 SHA512 3b4e66543245b2db7d1c255adf30112834935ab552a7d6773921838510417e000fd41c63fcab7e6be8df043f3daeab1cfcbebccaebf44f6185abfcb47898a3f2
diff --git a/x11-misc/mugshot/files/mugshot-0.4.2-python39.patch b/x11-misc/mugshot/files/mugshot-0.4.2-python39.patch
new file mode 100644
index 000000000000..b0443f7a3d33
--- /dev/null
+++ b/x11-misc/mugshot/files/mugshot-0.4.2-python39.patch
@@ -0,0 +1,36 @@
+From 643b3d005a8865c961b836aeae4c1f76711646e9 Mon Sep 17 00:00:00 2001
+From: Conrad Kostecki <conrad@kostecki.com>
+Date: Mon, 24 Aug 2020 23:58:10 +0200
+Subject: [PATCH] Add python3.9 compatiblity
+
+Starting with python3.9, launching of mugshot will fail,
+as getiterator() been deprecated since Python 2.7,
+and has been removed in Python 3.9. Using iter() will fix that.
+
+Signed-off-by: Conrad Kostecki <conrad@kostecki.com>
+---
+ mugshot_lib/Builder.py | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/mugshot_lib/Builder.py b/mugshot_lib/Builder.py
+index 7297541..6c08d70 100644
+--- a/mugshot_lib/Builder.py
++++ b/mugshot_lib/Builder.py
+@@ -89,7 +89,7 @@ def add_from_file(self, filename):
+ tree = ElementTree()
+ tree.parse(filename)
+
+- ele_widgets = tree.getiterator("object")
++ ele_widgets = tree.iter("object")
+ for ele_widget in ele_widgets:
+ name = ele_widget.attrib['id']
+ widget = self.get_object(name)
+@@ -111,7 +111,7 @@ def add_from_file(self, filename):
+ if connections:
+ self.connections.extend(connections)
+
+- ele_signals = tree.getiterator("signal")
++ ele_signals = tree.iter("signal")
+ for ele_signal in ele_signals:
+ self.glade_handler_dict.update(
+ {ele_signal.attrib["handler"]: None})
diff --git a/x11-misc/mugshot/mugshot-0.4.2-r1.ebuild b/x11-misc/mugshot/mugshot-0.4.2-r1.ebuild
index c547ba1e9538..a39fccdd02af 100644
--- a/x11-misc/mugshot/mugshot-0.4.2-r1.ebuild
+++ b/x11-misc/mugshot/mugshot-0.4.2-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=7
DISTUTILS_USE_SETUPTOOLS="no"
-PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1 gnome2-utils xdg-utils
@@ -59,6 +59,8 @@ BDEPEND="
S="${WORKDIR}/${PN}-${P}"
+PATCHES=( "${FILESDIR}/${PN}-0.4.2-python39.patch" )
+
python_install() {
distutils-r1_python_install