summaryrefslogtreecommitdiff
path: root/x11-misc/mugshot
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-08 11:28:34 +0000
commit24fd814c326e282c4321965c31f341dad77e270d (patch)
tree033d63b33c21a3209964ab56005bb9bdd523630d /x11-misc/mugshot
parent129160ec854dca4c3fedb5bcfbcb56930371da0f (diff)
gentoo resync : 08.01.2021
Diffstat (limited to 'x11-misc/mugshot')
-rw-r--r--x11-misc/mugshot/Manifest2
-rw-r--r--x11-misc/mugshot/mugshot-0.4.3.ebuild79
2 files changed, 81 insertions, 0 deletions
diff --git a/x11-misc/mugshot/Manifest b/x11-misc/mugshot/Manifest
index 6a065482eb4d..808e421fbac1 100644
--- a/x11-misc/mugshot/Manifest
+++ b/x11-misc/mugshot/Manifest
@@ -1,4 +1,6 @@
AUX mugshot-0.4.2-python39.patch 1369 BLAKE2B e006525dae248e4e8d04a01932f74371846c2757c085f5a0afc634f2c163c81918e6130ca796bcf122645bb7bd4e33348eea3ed0d926ff867028ab84641bf67a SHA512 c3868bec2772e7834bae8de87c2407986aacca1d32125631da92788ac9ae03e5a688b36ff6090792990f6c3163ecae1623eccd84349dc0099b4809258f14793b
DIST mugshot-0.4.2.tar.gz 121020 BLAKE2B c092e25273dbd8ef9cbfbc001fb5f86b134ed8f9bf5d84993d5f46664f17eb74eda5c121ee70b5f0c4b0adb5aa1fc4d21d8c59d3f0cf4a4f67991d06690f5aa5 SHA512 721629cf4a7e4d84fd8505279cf88c88ac88c7b6c995ac84a2fd6a9b978c92716bbe20d7b0301ca70e99c007698e4cddf41b6cf1111bf496eec4d39591cd9ed1
+DIST mugshot-0.4.3.tar.gz 128500 BLAKE2B 88ed4a9a0efa70a14d90b831d00ad8c98d7c6dc4eff0e319e5ad08e904b0c0cf2c15bb26198f4ae1248e85959c08af165c9b6dc917dce35d986fdd73ff67eed8 SHA512 b5e91288b4de30124bd84c44b8f2a70e043af12e1f9580d07b13344b6c0343399037aadf153ea216d61cd12e4891ebb15557f1ad62c3b4d7c49584fa004ae65c
EBUILD mugshot-0.4.2-r1.ebuild 1587 BLAKE2B 4c48a5849b55e9d6a21974bcb7c102ed6d6cc1b29685066e2aef2776931bcd3488b7c6a351b3a7dcec9bceb582e1fc688c5b919ae6db0f5f863d9fa832514fb1 SHA512 0b02356145d66c3d0e00a13db08756f1547050e98fa864b34e3c73ec2bbef7fd239a4f72d34864c4540970fb0ebd6fa8f0c774c6379268b3d7de4f370c704e69
+EBUILD mugshot-0.4.3.ebuild 1535 BLAKE2B c551eda62f7f5ff5e955c2418626eb66c19b29b1e299b0b13ed564c4cfb3fc3d0bee65aa206258b2c14806794828a99d21c86b15bf51d27f270f9ff313bc926f SHA512 3506c7a52fc30815943684a3225ea2e65557b7f7cdd679ea4d13892234d8af5c065b5fcf4dda49e6c0b0400dd7a65c64287f2c26f98bb8e306270d1c9df7275d
MISC metadata.xml 943 BLAKE2B b39c09aa84b6a1f25d001e073b2c369af9ebebb7448fff5b3abc83898516963e117c33d1c03fb6db72422e4b20c065ed78e711326f28912e1ed5321b232bbee1 SHA512 3b4e66543245b2db7d1c255adf30112834935ab552a7d6773921838510417e000fd41c63fcab7e6be8df043f3daeab1cfcbebccaebf44f6185abfcb47898a3f2
diff --git a/x11-misc/mugshot/mugshot-0.4.3.ebuild b/x11-misc/mugshot/mugshot-0.4.3.ebuild
new file mode 100644
index 000000000000..e739d980480c
--- /dev/null
+++ b/x11-misc/mugshot/mugshot-0.4.3.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS="no"
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1 gnome2-utils xdg-utils
+
+DESCRIPTION="A lightweight user-configuration application"
+HOMEPAGE="https://github.com/bluesabre/mugshot"
+SRC_URI="https://github.com/bluesabre/${PN}/archive/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome libreoffice webcam"
+
+COMMON_DEPEND="
+ dev-libs/gobject-introspection
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+
+"
+
+RDEPEND="
+ ${COMMON_DEPEND}
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ sys-apps/accountsservice
+ sys-apps/shadow
+ gnome? ( gnome-base/gnome-control-center )
+ libreoffice? (
+ || (
+ app-office/libreoffice-bin
+ app-office/libreoffice
+ )
+ )
+ webcam? (
+ media-libs/gstreamer:1.0
+ media-libs/gst-plugins-good:1.0
+ gnome? (
+ media-libs/clutter-gtk[introspection]
+ media-video/cheese[introspection]
+ )
+ )
+"
+
+DEPEND="
+ ${COMMON_DEPEND}
+ x11-libs/gtk+:3[introspection]
+"
+
+BDEPEND="
+ dev-python/python-distutils-extra[${PYTHON_USEDEP}]
+ dev-util/intltool
+"
+
+S="${WORKDIR}/${PN}-${P}"
+
+python_install() {
+ distutils-r1_python_install
+
+ python_optimize
+
+ # Since DOCS are installed twice, remove the wrong path
+ rm -r "${ED}"/usr/share/doc/mugshot || die
+}
+
+pkg_postinst() {
+ gnome2_schemas_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_schemas_update
+ xdg_icon_cache_update
+}