summaryrefslogtreecommitdiff
path: root/x11-misc/mozo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-30 17:27:54 +0100
commitf70a1bfc721336d4fc7dfb711c2f518a6b18cf16 (patch)
treee907cb121b30e3c1df1710719c0ddf4029597a47 /x11-misc/mozo
parentdb063b515939ab15261136b24e4bc44386335c0c (diff)
gentoo resync : 30.09.2020
Diffstat (limited to 'x11-misc/mozo')
-rw-r--r--x11-misc/mozo/Manifest1
-rw-r--r--x11-misc/mozo/mozo-1.24.0-r1.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/x11-misc/mozo/Manifest b/x11-misc/mozo/Manifest
index 40d991cd3164..0119a9277b00 100644
--- a/x11-misc/mozo/Manifest
+++ b/x11-misc/mozo/Manifest
@@ -1,3 +1,4 @@
DIST mozo-1.24.0.tar.xz 228180 BLAKE2B 6eb880b82dcb608f84efd8df74e77812f9da68dfa877ec896c6f04fa18088e8e4a82641c715e3620201dbb8a1bea8bb4ded09dd72f50770edae09c1326cbf453 SHA512 e0d217d2e7bb7d2c8df777e51bfb20e8bf4fa1bee0f9f3a9348ec1c8501b386a4afbd8848735ecfa61a0f9576382d784d3ef5b884a2a34af6ba33d3a126fe193
+EBUILD mozo-1.24.0-r1.ebuild 1313 BLAKE2B 245b391e83ec524f3a14f772bccd9771d67ee65bb98b39dd085ec3a70c62fc992792e1aaea7d1f7197e797a6421470f3debacca3ccd9bec4e1f7c9e95321af66 SHA512 5099b3d2be89196d4b177c7186a7ed78dc250f9fcf285cba70c62a055e36da3822b045cacc95c5ae78d8fb325a73fe737bfb30b3014dc9478e9a5f96a6880e4c
EBUILD mozo-1.24.0.ebuild 1311 BLAKE2B 31a5bb689aff98fe1f37caea0a4f856262592214f24621ed6be18fba2563c601e0c41f37e96e2605104f2bae7473135e27bf0a7a7530480cec2eab00ba22cf8a SHA512 d7ffdb97ca09abe2814c244accd3d622fced0e385c1723ac22d925ca97e7b9358382540718cb877996dc7d3108156b9a9fc5c866f34e564eb055202d74e7bb56
MISC metadata.xml 333 BLAKE2B 9901ffa7d882f0f741c95670130db70920ebbe94af75b8d9b72f48f8eb1b48d9425b7ff49dafbe001e5287ff3eafd2d60a8760a262ab6601fecc63642e242591 SHA512 eb3bc4b3cf1cfde5f96cd414138790deae0435e8ba41576e1e44b150defd5fdda0b921d4dbb0798b9653ad5aa7690247fb69cd25d03752f8bde8017419596a76
diff --git a/x11-misc/mozo/mozo-1.24.0-r1.ebuild b/x11-misc/mozo/mozo-1.24.0-r1.ebuild
new file mode 100644
index 000000000000..8977a145b152
--- /dev/null
+++ b/x11-misc/mozo/mozo-1.24.0-r1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_6,3_7,3_8} )
+PYTHON_REQ_USE="xml"
+
+inherit mate python-r1
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="Mozo menu editor for MATE"
+LICENSE="GPL-2+ GPL-3+ LGPL-2+ LGPL-2.1+"
+SLOT="0"
+IUSE=""
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ >=dev-python/pygobject-3:3[${PYTHON_USEDEP}]
+ >=mate-base/mate-menus-1.21.0[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ >=x11-libs/gtk+-3.22:3[introspection]
+ !!x11-misc/mate-menu-editor
+"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/libintl
+"
+
+DEPEND="${COMMON_DEPEND}
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ mate_src_prepare
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir mate_src_configure \
+ --disable-icon-update
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_test() {
+ python_foreach_impl run_in_build_dir emake check
+}
+
+src_install() {
+ installing() {
+ mate_src_install
+
+ # Massage shebang to make python_doscript happy
+ sed -e 's:#! '"${PYTHON}:#!/usr/bin/python:" \
+ -i mozo || die
+
+ python_doscript mozo
+ python_optimize
+ }
+
+ python_foreach_impl run_in_build_dir installing
+}