summaryrefslogtreecommitdiff
path: root/x11-misc/mozo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
commiteccb70a7f91b2d22582587f26d1a28bb31408b45 (patch)
tree3223e1fd54201bcf4ebecac6fbe87361cbe643e2 /x11-misc/mozo
parenta2810985afabcc31d3eace5e61d8ea25b852ba17 (diff)
gentoo resync : 18.05.2019
Diffstat (limited to 'x11-misc/mozo')
-rw-r--r--x11-misc/mozo/Manifest2
-rw-r--r--x11-misc/mozo/mozo-1.22.1.ebuild66
2 files changed, 68 insertions, 0 deletions
diff --git a/x11-misc/mozo/Manifest b/x11-misc/mozo/Manifest
index 43e43066de49..9855dec43040 100644
--- a/x11-misc/mozo/Manifest
+++ b/x11-misc/mozo/Manifest
@@ -1,3 +1,5 @@
DIST mozo-1.22.0.tar.xz 178924 BLAKE2B 6cc74cbdb7342d926483948391798cc9b0be66b63bba758b7ec8cea3f5555ae01f1ecf279053612ed060a283076bdac1a9ef8bd15e3cfe61d96685aeee168ae0 SHA512 f3d60e94d9bf5fdd435320856563622f0687cc2844a3d51473bcef5c442f4938a4030533271ead2fd88fb0ce805c16b40d629e5a69fc642e7e670a1afd5745db
+DIST mozo-1.22.1.tar.xz 171976 BLAKE2B c4a1166b605d3fed68b71987dbf70b7f908aabc2c7266415b0d7ce4c8ccb93ad690c72ce83a708f9d3518cfba66128d2cd4bc5413432133299595cf4d2c5a43c SHA512 6cd4ed04d43ae064077fc78ed59644bf6efe4c65c26995742166c57333d470fbe95ca4f4037e786f16dc076e75d938868948e8c2e5c662f35d971b36992f1a9b
EBUILD mozo-1.22.0.ebuild 1244 BLAKE2B ae23b51bacfed9815d26460f2c7c0242f4a3eb7c28d64e4fc53a73270268ffc684f02857fade291e1cbb808f8358516327b3ec1bfbf4fa7772f4339fc91d8cb2 SHA512 fa4dc0fb9fef1d17abe494d869739f0c80217dfdd7e12acfb312a6ea3ba1598526d9f2e4243367a913a03a8767c8a9d97be0bdc679c5a6503704b2636a3b7da1
+EBUILD mozo-1.22.1.ebuild 1246 BLAKE2B 592a0aefefe293aac4f5939dbd2273905ede3fcd2710b707da5951a91f0e3e172fa3e38ff1b718c27e07d0a7476a4b4c9d6dbaa2e9edfc1c8711d43f7d7b33d4 SHA512 a6a3d232d8ac51fe27eb3d399556831bd4cf40f339b3205ae063339c96ec3f5cec35d1255793b9c50890caef875ab696f2e46be8f97f534c0203c3cb926c7ec1
MISC metadata.xml 333 BLAKE2B 9901ffa7d882f0f741c95670130db70920ebbe94af75b8d9b72f48f8eb1b48d9425b7ff49dafbe001e5287ff3eafd2d60a8760a262ab6601fecc63642e242591 SHA512 eb3bc4b3cf1cfde5f96cd414138790deae0435e8ba41576e1e44b150defd5fdda0b921d4dbb0798b9653ad5aa7690247fb69cd25d03752f8bde8017419596a76
diff --git a/x11-misc/mozo/mozo-1.22.1.ebuild b/x11-misc/mozo/mozo-1.22.1.ebuild
new file mode 100644
index 000000000000..9c950c49491a
--- /dev/null
+++ b/x11-misc/mozo/mozo-1.22.1.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{5,6} )
+PYTHON_REQ_USE="xml"
+
+inherit python-r1 mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="Mozo menu editor for MATE"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE=""
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ >=dev-python/pygobject-3:3[${PYTHON_USEDEP}]
+ >=mate-base/mate-menus-1.21.0[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ >=x11-libs/gtk+-3.22:3[introspection]
+ virtual/libintl
+ !!x11-misc/mate-menu-editor"
+
+RDEPEND="${COMMON_DEPEND}"
+
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.40
+ sys-devel/gettext:*
+ virtual/pkgconfig:*"
+
+src_prepare() {
+ mate_src_prepare
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir mate_src_configure \
+ --disable-icon-update
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_test() {
+ python_foreach_impl run_in_build_dir emake check
+}
+
+src_install() {
+ installing() {
+ mate_src_install
+
+ # Massage shebang to make python_doscript happy
+ sed -e 's:#! '"${PYTHON}:#!/usr/bin/python:" \
+ -i mozo || die
+
+ python_doscript mozo
+ }
+
+ python_foreach_impl run_in_build_dir installing
+}