summaryrefslogtreecommitdiff
path: root/x11-misc/mozo/mozo-1.24.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-21 13:54:09 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-21 13:54:09 +0000
commit454de691f3543d47dc89cd0b137eaa9ea4640cd3 (patch)
tree90ec469ff7d2e1b1fac0b0f98f32d49dacb30278 /x11-misc/mozo/mozo-1.24.0-r1.ebuild
parente393c0503a79342594a61547dc43f80f8bcc086e (diff)
gentoo auto-resync : 21:12:2022 - 13:54:08
Diffstat (limited to 'x11-misc/mozo/mozo-1.24.0-r1.ebuild')
-rw-r--r--x11-misc/mozo/mozo-1.24.0-r1.ebuild69
1 files changed, 0 insertions, 69 deletions
diff --git a/x11-misc/mozo/mozo-1.24.0-r1.ebuild b/x11-misc/mozo/mozo-1.24.0-r1.ebuild
deleted file mode 100644
index 53a32a721767..000000000000
--- a/x11-misc/mozo/mozo-1.24.0-r1.ebuild
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{8..10} )
-PYTHON_REQ_USE="xml(+)"
-
-inherit mate python-r1
-
-if [[ ${PV} != 9999 ]]; then
- KEYWORDS="amd64 ~arm ~arm64 x86"
-fi
-
-DESCRIPTION="Mozo menu editor for MATE"
-LICENSE="GPL-2+ GPL-3+ LGPL-2+ LGPL-2.1+"
-SLOT="0"
-IUSE=""
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
-
-COMMON_DEPEND="${PYTHON_DEPS}
- >=dev-python/pygobject-3:3[${PYTHON_USEDEP}]
- >=mate-base/mate-menus-1.21.0[introspection]
- x11-libs/gdk-pixbuf:2[introspection]
- >=x11-libs/gtk+-3.22:3[introspection]
- !!x11-misc/mate-menu-editor
-"
-
-RDEPEND="${COMMON_DEPEND}
- virtual/libintl
-"
-
-DEPEND="${COMMON_DEPEND}
- >=sys-devel/gettext-0.19.8
- virtual/pkgconfig
-"
-
-src_prepare() {
- mate_src_prepare
- python_copy_sources
-}
-
-src_configure() {
- python_foreach_impl run_in_build_dir mate_src_configure \
- --disable-icon-update
-}
-
-src_compile() {
- python_foreach_impl run_in_build_dir default
-}
-
-src_test() {
- python_foreach_impl run_in_build_dir emake check
-}
-
-src_install() {
- installing() {
- mate_src_install
-
- # Massage shebang to make python_doscript happy
- sed -e 's:#! '"${PYTHON}:#!/usr/bin/python:" \
- -i mozo || die
-
- python_doscript mozo
- python_optimize
- }
-
- python_foreach_impl run_in_build_dir installing
-}