summaryrefslogtreecommitdiff
path: root/x11-misc/meteo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-20 13:07:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-20 13:07:51 +0100
commit30114ae8ef07a32fea1e44a10b61f98c84142645 (patch)
tree1f5829906b913ee4637e04254cc50ffc1faab519 /x11-misc/meteo
parentaaa44376d7162304219748a3b6771d9a26fc80fe (diff)
gentoo auto-resync : 20:07:2023 - 13:07:51
Diffstat (limited to 'x11-misc/meteo')
-rw-r--r--x11-misc/meteo/Manifest2
-rw-r--r--x11-misc/meteo/meteo-0.9.9.2.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/x11-misc/meteo/Manifest b/x11-misc/meteo/Manifest
index 08027c6bb2a5..620607d37b7e 100644
--- a/x11-misc/meteo/Manifest
+++ b/x11-misc/meteo/Manifest
@@ -1,3 +1,5 @@
DIST meteo-0.9.9.1.tar.gz 598205 BLAKE2B ac66e84a04f087cf75f9101da0c80e68c132e0e5064aec4cb2ea609e93f48a2ef3eb51266805b2547b4839c82496b470d4bb07e4fa0538e2ebc691a9491606d8 SHA512 d148393acc47dab1886a25600adb2a3e2ff5cb313c0004d50a54106c61f3cbd26ff95d526d13a77a1d33ede2622ff2ea9277a8fdc1899ebf34581a5a6b36c861
+DIST meteo-0.9.9.2.tar.bz2 609059 BLAKE2B 77557c28c755065f5b2da6cef429df96342c67217650f3ca3e5282f14c93d095b0e4c3f7b5cdfd62374f41e543cce14080d85291019e4336acc5d9f8f09e06c9 SHA512 96f05fb2b84d0be73eb26e101edf2a03345a06c79a86ec6c9f5acbe8b32e4fbaf6f4d7b59b65eb69f4db8667e1178d5641792b259cf23c46d4dcaee8a2243a5a
EBUILD meteo-0.9.9.1-r3.ebuild 1143 BLAKE2B 6f73a841aa016cf081a8cb722f41ddddac781a4443ba4a0f452bc453007603fe73259397fa92e6314e52b25c2eb1960fe2ea7f5391d52ab0c8b7eb9727496362 SHA512 dd2d7bb17833ec36d131ad0f4c25323c183d12fb62b8a0082340d342b05efcf18465b589c3ec527ec2b53038057fab4aebfab748b927f5430304f32b96eab70d
+EBUILD meteo-0.9.9.2.ebuild 1144 BLAKE2B 05502b70c2cfa95227663c7d2ccdd1b45fd0c3324ffe949f09331951d55253a4ef60504c96aa3178b7d4fec9f127e6eb309c048ee3ef7a93ecebdfeb474f94b6 SHA512 78599e17671a0a12344eff2af455a01e3d6b1711e910d99d1a903ecfa63d1175404edd53c62538c0944804bcf41f699cb99f8415afb0edc36c2568e76f1117d5
MISC metadata.xml 317 BLAKE2B 8d51ee5c40d1db6568ae785c3280a14a8252b1fc6befd790b50377de20e500eaeb2652070ee8c235a4e366aa965cb055b5af7c7122707abc5e150d0094f50928 SHA512 f8a1e901faf76d570c1066957383de9d98dc9a1d3c38efef9e8414c1d6438eeae26aaefb99d16706255d46e098eb7263e57aa1eab113d74f00a46ebe0510fb49
diff --git a/x11-misc/meteo/meteo-0.9.9.2.ebuild b/x11-misc/meteo/meteo-0.9.9.2.ebuild
new file mode 100644
index 000000000000..043a307df6fa
--- /dev/null
+++ b/x11-misc/meteo/meteo-0.9.9.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..12} )
+inherit gnome2-utils meson python-any-r1 vala xdg
+
+DESCRIPTION="Forecast application using OpenWeatherMap API"
+HOMEPAGE="https://gitlab.com/bitseater/meteo"
+SRC_URI="https://gitlab.com/bitseater/meteo/-/archive/${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+# One test needs network (#828052), the other simply checks desktop file
+# validation, that we also test with our QA tests
+RESTRICT="test"
+
+DEPEND="
+ dev-libs/libayatana-appindicator:0
+ dev-libs/glib:2
+ dev-libs/json-glib
+ net-libs/libsoup:2.4
+ net-libs/webkit-gtk:4
+ x11-libs/gtk+:3
+"
+RDEPEND="${DEPEND}
+ gnome-base/gsettings-desktop-schemas
+ x11-themes/hicolor-icon-theme
+"
+BDEPEND="${PYTHON_DEPS}
+ dev-libs/appstream-glib
+ virtual/pkgconfig
+ $(vala_depend)
+"
+
+src_configure() {
+ vala_setup
+ meson_src_configure
+}
+
+src_install() {
+ meson_src_install
+ dosym com.gitlab.bitseater.meteo /usr/bin/meteo
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}