summaryrefslogtreecommitdiff
path: root/x11-misc/menulibre
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-21 19:03:35 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-21 19:03:35 +0000
commit0ebf740b9c9bc7c10ac41bea315ecc6c01c79166 (patch)
tree15bb76d57cfb8652fd2627a24007e0bb92ec4a99 /x11-misc/menulibre
parent5b5df25227111ef465caf5c52bcfb66dac3219cd (diff)
gentoo resync : 21.01.2018
Diffstat (limited to 'x11-misc/menulibre')
-rw-r--r--x11-misc/menulibre/Manifest2
-rw-r--r--x11-misc/menulibre/menulibre-2.1.4.ebuild68
2 files changed, 70 insertions, 0 deletions
diff --git a/x11-misc/menulibre/Manifest b/x11-misc/menulibre/Manifest
index 13399baf7d08..e4f6f60183da 100644
--- a/x11-misc/menulibre/Manifest
+++ b/x11-misc/menulibre/Manifest
@@ -1,3 +1,5 @@
DIST menulibre-2.1.3.tar.gz 231336 BLAKE2B f15f962b41071f40cebdaa3fbab082932f1acad30026b89bb2b4672a860b4f7cc3caa668eadee48195a091783b6a8d5558ca44ed05034640247cad02394d3b93 SHA512 0a9040bcb311fe993238e5d1fc459db2400466c538c729ecd5bf2ff20cf9c7300ef2543c56ae4ef7cfa44cd66768ee9a9001ab997fd2507d8d74a246b2029c7a
+DIST menulibre-2.1.4.tar.gz 414546 BLAKE2B 4c6420e6559415dd4be6aee37af43f820f85bb5d98ce4c3b475d977c1511d4ad30f1fb3db8aff94569a3dc0afa4d75887bed8247cd8d48c673bcb106cfa11b52 SHA512 48322d7187d77a63253ee5d8d269b473e36bab4d02f1442b8e4c66070d372e3eba4247b923932688640092e16d51ea41bef42571694980099c279a3526b9e56a
EBUILD menulibre-2.1.3.ebuild 1726 BLAKE2B 25f6a035bb3a32ff4ec22a6c0147c0b4c6e23501d030a5620a9068f223d17d34f70a09b3b27fe68dbd9ada6a2183d0c57aac7261c065ac033ba1ca0d61cc50d6 SHA512 35b0a13f101aa205ce6fce26f345b46d5fae1131e4bce61caf8630bbc1109f7e4e353da300e83b921c5edf33421b9f6d3951de38bf6c38baeb3e546eb14551cb
+EBUILD menulibre-2.1.4.ebuild 1728 BLAKE2B 90daacc086f6f5f06721a9427b5426fd90c2ede7f5cab19dbfacb52ecc58998614ab68682548deb0ae924316a1088fc5c7d0c61b5a7c9867a875d9f647be7866 SHA512 ede22acec5b50f1f181430840ca679900c8dc23435a96768c6b07f340f807cf28e470b7ec777c0a49b624312563c4e8ab19078802a71d493a7ac6877d577bbe8
MISC metadata.xml 353 BLAKE2B 6064836036ff045dce0bc62fe8b822aefcd75b1cbb5746e12c2a2c5399802c1412b4f6bb9f9582785d5f8cff63d61f9f0c71505fd593e649e26c30f7c7019d6a SHA512 256e7ca3b20708caea270d07348c477b3d9e8300739092ad80468f4ab60e5e85b21246cf906d51a1929e627d27ed62bcf23136a3b8edc684c4ba1b53e3282454
diff --git a/x11-misc/menulibre/menulibre-2.1.4.ebuild b/x11-misc/menulibre/menulibre-2.1.4.ebuild
new file mode 100644
index 000000000000..f05ba92dfc02
--- /dev/null
+++ b/x11-misc/menulibre/menulibre-2.1.4.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python3_{4,5,6} )
+PYTHON_REQ_USE="xml"
+DISTUTILS_IN_SOURCE_BUILD=1
+inherit distutils-r1 eutils gnome2-utils versionator
+
+DESCRIPTION="Advanced freedesktop.org compliant menu editor"
+HOMEPAGE="https://bluesabre.org/projects/menulibre/"
+SRC_URI="https://launchpad.net/${PN}/$(get_version_component_range 1-2)/${PV}/+download/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-python/python-distutils-extra[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ dev-libs/gobject-introspection
+ dev-python/psutil[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ gnome-base/gnome-menus[introspection]
+ x11-libs/gdk-pixbuf[X,introspection]
+ x11-libs/gtk+:3[X,introspection]
+ x11-libs/gtksourceview:3.0[introspection]
+ x11-themes/hicolor-icon-theme
+"
+
+python_prepare_all() {
+ # too many categories
+ sed -i \
+ -e 's/X-GNOME-Settings-Panel;X-GNOME-PersonalSettings;DesktopSettings;X-XFCE;//' \
+ menulibre.desktop.in || die
+
+ local i
+ # fix incorrect behavior when LINGUAS is set to an empty string
+ # https://bugs.launchpad.net/python-distutils-extra/+bug/1133594
+ if [[ -n "${LINGUAS+x}" ]] ; then # if LINGUAS is set
+ for i in $(cd "${S}"/po ; for p in *.po ; do echo ${p%.po} ; done) ; do # for every supported language
+ if ! has ${i} ${LINGUAS} ; then # if language is disabled
+ rm po/${i}.po || die
+ fi
+ done
+ fi
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+}
+
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}