summaryrefslogtreecommitdiff
path: root/x11-misc/mate-notification-daemon
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-14 11:10:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-14 11:10:11 +0100
commit81b8f20732954c4508baf2f77472b5435e3f851f (patch)
tree4180177cb7ba85eab50159ce96218c2419fb24a6 /x11-misc/mate-notification-daemon
parent946859e0e36904cffb3e0ccbccb6b7b1347c1cc8 (diff)
gentoo auto-resync : 14:09:2022 - 11:10:10
Diffstat (limited to 'x11-misc/mate-notification-daemon')
-rw-r--r--x11-misc/mate-notification-daemon/Manifest2
-rw-r--r--x11-misc/mate-notification-daemon/mate-notification-daemon-1.26.0.ebuild63
2 files changed, 65 insertions, 0 deletions
diff --git a/x11-misc/mate-notification-daemon/Manifest b/x11-misc/mate-notification-daemon/Manifest
index dfaf90c584cc..aff2353d4b61 100644
--- a/x11-misc/mate-notification-daemon/Manifest
+++ b/x11-misc/mate-notification-daemon/Manifest
@@ -1,4 +1,6 @@
AUX org.freedesktop.Notifications.service 94 BLAKE2B 1a97aac2db9c803c9e4babf9067283b564a1eecb1d251aee3a5e66b8a4f63d2554e3e09ea06749383ce3d5b8e77c8cc3bd87ae2dde48ae8feb4886ecaf7a3c27 SHA512 0575cbfc094455c0a2f04faa534a5e0d9cc41e6d9566ab9bcb0fcbce99e142213ded786ad00c36dc434ae1b9208d34d234a341dfc86adb72925dad0ee2b25f97
DIST mate-notification-daemon-1.24.2.tar.xz 396156 BLAKE2B 64bbada24bc53f296076ff80b364e156fecfe28f4b1d8b77a0f05910939ccc2378e0635861442cc5cff8c95db5ccda55484de8aaf3315e28eb8df75c1a4bc20d SHA512 be9db249bec6dc2206d69998b972f06ab4e2ee5c30b5bcf44c43b508954a9984a37bc9a2fe9989aec55969492256ed742fb2a9618b751e47ff43b66c383c1bd4
+DIST mate-notification-daemon-1.26.0.tar.xz 421032 BLAKE2B 3f55a281cc51e63245371a1bf4ddadb2be4fa09bf16a4ffac701d4530f519a65e2ff69c7e58e6589fa923d3af86315e36d5445a6a1915a6857271933605eaaac SHA512 5249cf14ba93f2e74b9774226c5d0f5e90a517df07569e16a23af7053f5ef160afe98c8a3452baf80c243272763eee1fde0b84f434f55df1f9de26298361a1dc
EBUILD mate-notification-daemon-1.24.2.ebuild 1006 BLAKE2B 315c7f21e75b86bc4632ec922d721bd4e78bf2146316cf7047a8334245589705b6f023543490e8141f6f292006e3f37cfbf693592730f344369906c7e3e103c6 SHA512 ba1f70af4c38f6abee3c14db72889ca206bceaabbb7ac3824b9848d15bad54d4d6f40cfb227e073f83a6d660770f9bbdc51fe164c321dc1a0fd96a878e0231d2
+EBUILD mate-notification-daemon-1.26.0.ebuild 1173 BLAKE2B 431791089c750c075b3363f48d1d5683f036b669016462934ba0c0cb0f1d157ad4af53fae1c73fb38da350d322a9260fa9e0174e9c4eb60daca6b2baa827937f SHA512 b971183a2671864450a3783daba821a7f40b15a984cb6be20ef0bb35faf7ea5340191640141af512f426e00a448589c814779705fce10ffa7dacdc79830492d9
MISC metadata.xml 354 BLAKE2B 1a12ca172c08806c1c9d2bbd6b2342fcbfde32b800af7bac33746f0611bb6c4376d558ad8b4a69008cc8ce78207246778d894e3454b52c1483606aa4a93dc05d SHA512 fc721d4464481caf4112d0d09f3a3243f31ce2cf97430c7d638728d8461f60e5070591f9698983b06b78c748bca563fa0ece998032a724cf8257bf72213ca492
diff --git a/x11-misc/mate-notification-daemon/mate-notification-daemon-1.26.0.ebuild b/x11-misc/mate-notification-daemon/mate-notification-daemon-1.26.0.ebuild
new file mode 100644
index 000000000000..07ccfba40877
--- /dev/null
+++ b/x11-misc/mate-notification-daemon/mate-notification-daemon-1.26.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MATE_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+fi
+
+DESCRIPTION="MATE Notification daemon"
+LICENSE="GPL-2+ GPL-3+"
+SLOT="0"
+
+IUSE="nls X wayland"
+REQUIRED_USE="|| ( X wayland )"
+
+COMMON_DEPEND="dev-libs/atk
+ >=dev-libs/glib-2.50:2
+ >=dev-libs/libxml2-2.9.0
+ >=sys-apps/dbus-1
+ x11-libs/cairo
+ >=x11-libs/gdk-pixbuf-2.22:2
+ >=x11-libs/libnotify-0.7
+ >=x11-libs/gtk+-3.22:3
+ >=media-libs/libcanberra-0.4:0[gtk3]
+ X? (
+ x11-libs/libX11
+ >=x11-libs/libwnck-3:3
+ )
+ wayland? ( gui-libs/gtk-layer-shell )
+"
+
+RDEPEND="${COMMON_DEPEND}
+ !x11-misc/notify-osd
+ !x11-misc/qtnotifydaemon
+ !x11-misc/notification-daemon
+"
+
+DEPEND="${COMMON_DEPEND}
+ app-arch/xz-utils
+ dev-util/gdbus-codegen
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ mate-base/mate-panel
+"
+
+src_configure() {
+ mate_src_configure \
+ $(use_enable nls)
+ $(use_enable X x11) \
+ $(use_enable wayland)
+}
+
+src_install() {
+ mate_src_install
+
+ insinto /usr/share/dbus-1/services
+ doins "${FILESDIR}/org.freedesktop.Notifications.service"
+}