summaryrefslogtreecommitdiff
path: root/x11-misc/matchbox-keyboard/matchbox-keyboard-0.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/matchbox-keyboard/matchbox-keyboard-0.1-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/matchbox-keyboard/matchbox-keyboard-0.1-r1.ebuild')
-rw-r--r--x11-misc/matchbox-keyboard/matchbox-keyboard-0.1-r1.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/x11-misc/matchbox-keyboard/matchbox-keyboard-0.1-r1.ebuild b/x11-misc/matchbox-keyboard/matchbox-keyboard-0.1-r1.ebuild
new file mode 100644
index 000000000000..b98376f666de
--- /dev/null
+++ b/x11-misc/matchbox-keyboard/matchbox-keyboard-0.1-r1.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit versionator eutils
+
+DESCRIPTION="Matchbox-keyboard is an on screen 'virtual' or 'software' keyboard"
+HOMEPAGE="http://matchbox-project.org/"
+SRC_URI="http://matchbox-project.org/sources/${PN}/$(get_version_component_range 1-2)/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+
+KEYWORDS="amd64 ~arm ~hppa ppc x86"
+IUSE="debug cairo"
+
+DOCS=( AUTHORS ChangeLog INSTALL NEWS README )
+PATCHES=( "${FILESDIR}"/${PN}-0.1-r1-modernize_desktop.patch )
+
+DEPEND="x11-libs/libfakekey
+ cairo? ( x11-libs/cairo[X] )
+ !cairo? ( x11-libs/libXft )"
+RDEPEND="$DEPEND"
+
+src_configure() {
+ econf $(use_enable debug) $(use_enable cairo)
+}