summaryrefslogtreecommitdiff
path: root/x11-misc/magick-rotation
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/magick-rotation
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/magick-rotation')
-rw-r--r--x11-misc/magick-rotation/Manifest5
-rw-r--r--x11-misc/magick-rotation/magick-rotation-1.6.2-r2.ebuild95
-rw-r--r--x11-misc/magick-rotation/metadata.xml21
3 files changed, 121 insertions, 0 deletions
diff --git a/x11-misc/magick-rotation/Manifest b/x11-misc/magick-rotation/Manifest
new file mode 100644
index 000000000000..e7240bfe3a66
--- /dev/null
+++ b/x11-misc/magick-rotation/Manifest
@@ -0,0 +1,5 @@
+DIST magick-rotation-1.6.2.tar.bz2 103389 SHA256 e0decb8ffb6bd5b8ffd0f01df345f23041abe78cda97fbe7065772260a1a2520 SHA512 40252c4b57d304244f8f7a8b08448cb498efd9044406235f2d728a89c8b4888009c4e7a9f50cbb61b5620336eedf1abb1591e68e94a57b051f4d823acbcdff5f WHIRLPOOL 3aeea34a2a7cbf966a7c0ea3bd13810e2a7a2015bc1f068566ce0515636bcb661e728af6682eea80b39624a3947a8219b9144a296f7c7fe9526d952d21cab49f
+EBUILD magick-rotation-1.6.2-r2.ebuild 2424 SHA256 7356a1e2c12df5c581a74f4b7d549603f0cdb7711cf07fd0d14915eb90e3e393 SHA512 22187c36505f55c33d1e2cef0ea78b601c64b221fb4fc68988f96bc92457c7ca4b1fd17dc1d011000b67e2fb464f5cf3f2c5b94b3131f4830c9c573faa6f910e WHIRLPOOL 489ac5e3b2298f748648d1e24ef3e34f213e9a5e93c3619a7149c81fb8a017bba2f7c6e62b4addfe8235f69621d8eb0ba96d560b97ac00564f2d368278ec4503
+MISC ChangeLog 3160 SHA256 fdb2c07bc1582957acdc9a533b60da077d3bdd0d655edea0528722558e3f95eb SHA512 f4a879618c2d7a679ba2e537befdfd2c5f894423774b26b023061d3a36962537ebd62a5e554f5e67acbf0cd099508b7d04fb41f6806cb9d12272f439cf64f04c WHIRLPOOL 4c78f6a7f3976ab19fad954a80ee0aa5e685782ff062b17450a4f6e9bdb24cde2d7c2f70b2047ac4a9084bd0736ca66709409cb18df02dbd3c72dd2a572ccde0
+MISC ChangeLog-2015 1525 SHA256 10fba231b42d7fac511dcdc261fe795b2de8d062b0c435b4b3e618e821fda00a SHA512 d0054a9a6031a50a9d55b09ef1c5c9c6d3ca97d66d83e29a116710576cb9d6450f39a8fbaef37080a58822e3ab7b9339eeeffcc735c2aa4d34592affef90b72d WHIRLPOOL cca156d41a6b2eed2584d5c66594cd1cb5f3e7cd79dfec3a8af7adb9583e45eec22000c40ff03e07cf9169006dfba1ad636bc9278d01329d29ddeb5b4876be60
+MISC metadata.xml 674 SHA256 d16d7746c77b81d9dc8ceb19b26aca1394a60de715284eab4975542ae4f5299d SHA512 2a3b9db9c76e7f8f5f21f8d34fa059904b0bb75793d32a8d4b88410c9f5af36a7732969751177ca950a824af97f305aef8864fe9cb4dcd26ea9bcf44b6bedf52 WHIRLPOOL 1eed210238ebe12f18bd1b5014d9c15df12873339b5bb76a96c246237b01e58a7cb95e1e23090ead3244c7ff77b011504fe6acc0dff0449b66ca390f8fcc37b5
diff --git a/x11-misc/magick-rotation/magick-rotation-1.6.2-r2.ebuild b/x11-misc/magick-rotation/magick-rotation-1.6.2-r2.ebuild
new file mode 100644
index 000000000000..43a71929ba58
--- /dev/null
+++ b/x11-misc/magick-rotation/magick-rotation-1.6.2-r2.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="xml"
+inherit eutils python-single-r1 toolchain-funcs udev user versionator
+
+MY_PV=$(get_version_component_range 1-2)
+
+DESCRIPTION="Application that rotates tablet pc's screen automatically, based on orientation"
+HOMEPAGE="https://launchpad.net/magick-rotation"
+SRC_URI="https://launchpad.net/magick-rotation/trunk/${MY_PV}/+download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ x11-libs/libX11
+ x11-libs/libXrandr"
+
+RDEPEND="${DEPEND}
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ dev-python/py-notify[${PYTHON_USEDEP}]
+ x11-apps/xinput"
+
+# there are no tests in package, default 'make check' does wrong things, bug #453672
+RESTRICT="test"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+ enewgroup magick
+}
+
+src_prepare() {
+ # Remove unneeded files
+ rm -r apt_* installer_gtk.py MAGICK-INSTALL gset_addkeyval.py MagickIcons/MagickSplash.png MagickUninstall || die 'removing unneeded files failed'
+
+ # Fix Python shebangs
+ python_fix_shebang "${S}"
+
+ epatch_user
+}
+
+src_compile() {
+ my_compile() {
+ echo $(tc-getCC) $*
+ $(tc-getCC) $* || die 'compilation failed'
+ }
+
+ local suffix=
+ if use amd64; then
+ suffix=64
+ else
+ suffix=32
+ fi
+ my_compile "${CFLAGS} ${LDFLAGS} check.c -lX11 -lXrandr -o checkmagick${suffix}"
+}
+
+src_install() {
+ #TODO: add installation of GNOME Shell 3.2 extension
+ dobin checkmagick*
+
+ udev_dorules 62-magick.rules
+
+ python_moduleinto /usr/share/${PN}
+ python_domodule *.py
+
+ insinto /usr/share/${PN}/MagickIcons
+ doins MagickIcons/*.png
+
+ python_scriptinto /usr/share/${PN}
+ python_doscript magick-rotation xrotate.py
+
+ dodoc *.txt ChangeLog
+
+ make_desktop_entry /usr/share/${PN}/${PN} "Magick Rotation" /usr/share/${PN}/MagickIcons/magick-rotation-enabled.png "System;Utility;"
+}
+
+pkg_postinst() {
+ echo
+ elog "In order to use Magick Rotation with an on-screen keyboard and handwriting,"
+ elog "the following additional package may also be installed for use at run-time:"
+ elog
+ optfeature "Magick Rotation's default onscreen keyboard" media-gfx/cellwriter
+ echo
+
+ ewarn "in order to use Magick Rotation you have to be in the 'magick' group."
+ ewarn "Just run 'gpasswd -a <USER> magick', then have <USER> re-login."
+}
diff --git a/x11-misc/magick-rotation/metadata.xml b/x11-misc/magick-rotation/metadata.xml
new file mode 100644
index 000000000000..48d91f8744d3
--- /dev/null
+++ b/x11-misc/magick-rotation/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>evadim@evadim.ru</email>
+ <name>Vadim Efimov</name>
+ <description>Maintainer. Assign bugs to him</description>
+ </maintainer>
+ <maintainer type="person">
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ <description>Proxy maintainer. CC him on bugs</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="launchpad">magick-rotation</remote-id>
+ </upstream>
+</pkgmetadata>