summaryrefslogtreecommitdiff
path: root/x11-misc/macopix
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-04 12:02:00 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-04 12:02:00 +0100
commiteab5731cdf11d4ae8cdf111461d46fd96c5bdd37 (patch)
treece35c6d01b5ff5de95c3a20fef853b9a6518ad2e /x11-misc/macopix
parentb7ebc951da8800f711142f69d9d958bde67a112d (diff)
gentoo resync : 04.05.2019
Diffstat (limited to 'x11-misc/macopix')
-rw-r--r--x11-misc/macopix/Manifest1
-rw-r--r--x11-misc/macopix/macopix-1.7.4-r2.ebuild82
2 files changed, 83 insertions, 0 deletions
diff --git a/x11-misc/macopix/Manifest b/x11-misc/macopix/Manifest
index 335118445f74..18e07f5bfdc4 100644
--- a/x11-misc/macopix/Manifest
+++ b/x11-misc/macopix/Manifest
@@ -11,4 +11,5 @@ DIST macopix-mascot-pia2-euc-ja-1.02.tar.gz 191520 BLAKE2B 7fa81c34df02751563fff
DIST macopix-mascot-triangle_heart-euc-ja-1.02.tar.gz 310099 BLAKE2B f52f2ad14cd9c76f32eb8c582bd07886f50eb6ae2615766306081ea1850b51b205b5177831ca30ab4049fd07081ff42d5dc7c9858efa49ab79a6acf2135ff9b1 SHA512 133a3446a3713192ffef84cd381065b2a99db2eb0dd18692d54e7974eb26aa63eef6d051466ddf89152f6baa8e4625ae6e7e975cf944dd12e0b6cc17c56e5673
DIST macopix-mascot-tsukihime-euc-ja-1.02.tar.gz 616138 BLAKE2B 8616fb0f3b8e4b72c6576dfada3794dc3e387d250e3a6f64eb2b290ef793f62c43f20ef9c03d2b309f4fd3860ce828a562f28ec37ca55ce8e2831315ccbd8a63 SHA512 226a175846a1f81a5aeedab6d7b85e38903d3b85a88a4a2c9a91365ba8a149a9ee54d6174bf8c4595cbe6542d3afcebd440a4185402c2139310664059515a2c5
EBUILD macopix-1.7.4-r1.ebuild 1820 BLAKE2B c9fa77abbfbbde5c4ec3b2b09ec078223bb3ed20dc44b4ca7ea05bdb5f83310d82320b2599510eb5c4157ae3be48503b117db1fb65a0fad9fd48e8769e5aef5b SHA512 1d11c0d2c98b16f5544d4a8895d539dfa9a191f64d4ca55f5f4d1bc2e49f42af13b92e7fd15c5ef29f1fd64d8e6bee93fe31ab64cdf52c0255efd53dba393cca
+EBUILD macopix-1.7.4-r2.ebuild 1770 BLAKE2B f707f59869697cb0650f4ea63571fa7ca71730bda7131b4b43adc4272bcd073f745f96544bcd30263f43646ee434c7df46689a10c3af07c1793ded2ae9a621d1 SHA512 35e71d8325425b5e7be9303ca0a822e8f46b2a36fe1470e7bbfd215f0227b8a5dbe4b0ca19d07c92110e760a086c9c41d09f5827efa2c7b937d04c5e987c3642
MISC metadata.xml 272 BLAKE2B 4dbd2b5ae92564a97b2a06ab0ec6562e8dce2dd636aaf0788ee09f8688ca5d5b6483084a65366dfbe6d144d30170e5558bc5759adecb96abb405ea96a5147285 SHA512 ebe67da08587903b5b82fc194aa3c8f1ab65371f60d2c134928362e089550d9e9fd9531bffe8b676a345b5bf0ab209ce7f50d37d98201a88176f002e17582493
diff --git a/x11-misc/macopix/macopix-1.7.4-r2.ebuild b/x11-misc/macopix/macopix-1.7.4-r2.ebuild
new file mode 100644
index 000000000000..a862222fef25
--- /dev/null
+++ b/x11-misc/macopix/macopix-1.7.4-r2.ebuild
@@ -0,0 +1,82 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools flag-o-matic
+
+DESCRIPTION="MaCoPiX (Mascot Constructive Pilot for X) is a desktop mascot application"
+HOMEPAGE="http://rosegray.sakura.ne.jp/macopix/index-e.html"
+
+BASE_URI="http://rosegray.sakura.ne.jp/macopix"
+SRC_URI="${BASE_URI}/${P}.tar.bz2"
+
+# NOTE: These mascots are not redistributable on commercial CD-ROM.
+# The author granted to use them under Gentoo Linux.
+MACOPIX_MASCOTS="
+ macopix-mascot-HxB-euc-ja-0.30
+ macopix-mascot-marimite-euc-ja-2.20
+ macopix-mascot-cosmos-euc-ja-1.02
+ macopix-mascot-mizuiro-euc-ja-1.02
+ macopix-mascot-pia2-euc-ja-1.02
+ macopix-mascot-tsukihime-euc-ja-1.02
+ macopix-mascot-triangle_heart-euc-ja-1.02
+ macopix-mascot-comic_party-euc-ja-1.02
+ macopix-mascot-kanon-euc-ja-1.02
+ macopix-mascot-one-euc-ja-1.02
+"
+
+for i in ${MACOPIX_MASCOTS} ; do
+ SRC_URI+=" ${BASE_URI}/${i}.tar.gz"
+done
+
+# programme itself is GPL-2, and mascots are free-noncomm
+LICENSE="GPL-2 free-noncomm"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gnutls nls"
+
+RDEPEND="
+ dev-libs/glib:2
+ media-libs/libpng:0=
+ sys-devel/gettext
+ x11-libs/gtk+:2
+ gnutls? ( net-libs/gnutls )
+ !gnutls? ( dev-libs/openssl:0= )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+PATCHES=(
+ "${FILESDIR}"/${P}-windres.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ append-libs -lX11
+
+ econf $(use_with gnutls)
+}
+
+src_install() {
+ default
+
+ dodoc AUTHORS ChangeLog* NEWS *README*
+
+ # install mascots
+ for d in ${MACOPIX_MASCOTS} ; do
+ einfo "Installing ${d}..."
+ cd "${WORKDIR}/${d}" || die
+ insinto /usr/share/"${PN}"
+ doins *.mcpx *.menu
+ insinto /usr/share/"${PN}"/pixmap
+ doins *.png
+ docinto "${d}"
+ dodoc README.jp
+ done
+}