summaryrefslogtreecommitdiff
path: root/x11-misc/lndir
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /x11-misc/lndir
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'x11-misc/lndir')
-rw-r--r--x11-misc/lndir/Manifest2
-rw-r--r--x11-misc/lndir/lndir-1.0.3-r2.ebuild44
-rw-r--r--x11-misc/lndir/lndir-9999.ebuild44
3 files changed, 90 insertions, 0 deletions
diff --git a/x11-misc/lndir/Manifest b/x11-misc/lndir/Manifest
index fa6afab68fec..b6acda5bf33e 100644
--- a/x11-misc/lndir/Manifest
+++ b/x11-misc/lndir/Manifest
@@ -1,3 +1,5 @@
DIST lndir-1.0.3.tar.bz2 114392 BLAKE2B 2e9feb3057f1508a118c4dd6212305e626ba25dd32296d35a553b5c42cb441e494d386d4c9afe15f150a9a8da2b7fac0ae7a128948544c4545ea740d7e7e21a6 SHA512 c9f03c825c627935abe399bf8292bbf69304cb9e9d65a4c860b49e32e2ed4dde25bf658a5ab2116cd215381d0a52f464a8a53469c27adddbd9fa2bfd135a7289
EBUILD lndir-1.0.3-r1.ebuild 329 BLAKE2B 9db3fce24ee36408c424c6aca65d16e8e56a7db7dad4d9733363b09183b8e7eb7b49f6a846fd4731bc212aee653d96fed30af6033cf3adf05d6236961c638152 SHA512 c5696fbfa2394fac512f6a2ab005af434570b3cc8fa2689d5aa61bd17dcf491cde2d894d9bb12e7b68bc166bb0f27f4001d8c5e4d7f619be59eee3fbd04446ec
+EBUILD lndir-1.0.3-r2.ebuild 882 BLAKE2B 8d818620a5e442cc56e9cf4c72d6ab63fa0a2f8d1b0b91a7641013cf727e7421642e6ed7b9639ecd656b0c9783633bea0f843ab2661179c6070ae2724e927ce8 SHA512 9330d8504ea7427de7c4132dab36fb0a9ea8c7cd432391863eeb9b37d14f77de0134c031723f273d483ca8d1626a5b0252fbbfa91476a5e3d586f1e72dbfe8ba
+EBUILD lndir-9999.ebuild 882 BLAKE2B 8d818620a5e442cc56e9cf4c72d6ab63fa0a2f8d1b0b91a7641013cf727e7421642e6ed7b9639ecd656b0c9783633bea0f843ab2661179c6070ae2724e927ce8 SHA512 9330d8504ea7427de7c4132dab36fb0a9ea8c7cd432391863eeb9b37d14f77de0134c031723f273d483ca8d1626a5b0252fbbfa91476a5e3d586f1e72dbfe8ba
MISC metadata.xml 230 BLAKE2B 70bf59e64305ef14908197f2aa7ffbc1769ade265097da68e001245451658af5921760c91cb74aae717543ea0017e2471fd94bfc5c4c447d2d60e2c23aa3b007 SHA512 d7a2643abd1904cc5ff4d91cbb6f1baeb7f75fd1db542c5e14f19412f4f0bd4b903f8e703a7662ba7482c79dac5529057760b6427599d35e0842755fd946e057
diff --git a/x11-misc/lndir/lndir-1.0.3-r2.ebuild b/x11-misc/lndir/lndir-1.0.3-r2.ebuild
new file mode 100644
index 000000000000..3009d675272b
--- /dev/null
+++ b/x11-misc/lndir/lndir-1.0.3-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="create a shadow directory of symbolic links to another directory tree"
+HOMEPAGE="https://www.x.org/wiki/ https://cgit.freedesktop.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/xorg/util/lndir.git"
+ inherit autotools git-r3
+ # x11-misc-util/macros only required on live ebuilds
+ LIVE_DEPEND=">=x11-misc/util-macros-1.18"
+else
+ SRC_URI="mirror://xorg/util/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+BDEPEND="
+ virtual/pkgconfig
+"
+RDEPEND=""
+DEPEND="
+ ${LIVE_DEPEND}
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ local econfargs=(
+ --disable-selective-werror
+ )
+
+ econf "${econfargs[@]}"
+}
diff --git a/x11-misc/lndir/lndir-9999.ebuild b/x11-misc/lndir/lndir-9999.ebuild
new file mode 100644
index 000000000000..3009d675272b
--- /dev/null
+++ b/x11-misc/lndir/lndir-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="create a shadow directory of symbolic links to another directory tree"
+HOMEPAGE="https://www.x.org/wiki/ https://cgit.freedesktop.org/"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/xorg/util/lndir.git"
+ inherit autotools git-r3
+ # x11-misc-util/macros only required on live ebuilds
+ LIVE_DEPEND=">=x11-misc/util-macros-1.18"
+else
+ SRC_URI="mirror://xorg/util/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+BDEPEND="
+ virtual/pkgconfig
+"
+RDEPEND=""
+DEPEND="
+ ${LIVE_DEPEND}
+ ${RDEPEND}
+ x11-base/xorg-proto
+"
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ local econfargs=(
+ --disable-selective-werror
+ )
+
+ econf "${econfargs[@]}"
+}