summaryrefslogtreecommitdiff
path: root/x11-misc/j4-dmenu-desktop
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /x11-misc/j4-dmenu-desktop
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'x11-misc/j4-dmenu-desktop')
-rw-r--r--x11-misc/j4-dmenu-desktop/Manifest4
-rw-r--r--x11-misc/j4-dmenu-desktop/j4-dmenu-desktop-2.17-r1.ebuild (renamed from x11-misc/j4-dmenu-desktop/j4-dmenu-desktop-2.17.ebuild)27
-rw-r--r--x11-misc/j4-dmenu-desktop/metadata.xml3
3 files changed, 24 insertions, 10 deletions
diff --git a/x11-misc/j4-dmenu-desktop/Manifest b/x11-misc/j4-dmenu-desktop/Manifest
index 05469706d543..03ad56bbf510 100644
--- a/x11-misc/j4-dmenu-desktop/Manifest
+++ b/x11-misc/j4-dmenu-desktop/Manifest
@@ -1,3 +1,3 @@
DIST j4-dmenu-desktop-2.17.tar.gz 33531 BLAKE2B c1dd82a444efdbbf2af644ee6cdba6746a81228c5f6b2d212d5ea248628855f1cd1c4dff091ae278eb8c6458db4934b60acd8e2dd9a9c88b32537e76878824b3 SHA512 7a41bb60a6b3afa7bf6229f08674d5f31e0152d0788a17edc210986d1b1f0d4fad13ffaa13c58ed7a0c5d2e67f8f95bb2a0f6556aeb0f2cc24c7d885b346325e
-EBUILD j4-dmenu-desktop-2.17.ebuild 844 BLAKE2B c7a6cd3d14f91e26e27012b8d47828753d3c966d146a10feb177aab0153cc6870266f7bc2b14cd24032ecaed9516c14ae3adddcd49b100d2b686df227fc6d3e4 SHA512 74f3fb875e880382c82077aafbb2a9c2174befb17456cf8601f18ff21604805c44a6152fe07513137b3d08c86411257a79832d5e82b750165a0c54e66d769070
-MISC metadata.xml 590 BLAKE2B b2f14516c9e17b71672913561ff260cb2cf7ff25d54eccacdbbfd4419224518815c0990ac2c29d7de087b86dac7c5b25be31f25993fb8a8f5b004ad5fe7cc5f3 SHA512 131576f1a9f0ccaa9cc79659e3889371df0a200d7184d1a8efa365ee089353fab875e55bd14d0a01e92c32583f3cafaacd18e8f8282300480d9cf67ad587d3ae
+EBUILD j4-dmenu-desktop-2.17-r1.ebuild 1186 BLAKE2B 8644a900bfb548b0988b171b12e3ba8c59c0261f8ce317a77c6ef77465bdc6a6598f723ba10b1fd15e5a0d8ec8e7f850f36971b519c32069dfb4e71c5f01aa4c SHA512 b71396ce7df1bc5f8926599ea6927fbc70f0ef2ee605512c6679de34bbfc07d8cb5bd04fddbd7ba9b4329c497d4465490d4d2c43ea87fce7ede7bcc75d3fd71d
+MISC metadata.xml 719 BLAKE2B 4eb56ae83ae7b2360e3bbe83ef36e06fb20552246d762a6345a68a4bc8f75583c3c891f258e839da9c3654a762d82695e87e2558287bdcb18b32b39c81c11676 SHA512 a50da4bde79c78ccbb92fd7823056fd6b6d8f006c12a58f88b3bf7a2d655ca3005e633986c622eb4e770168366a5c35d7768c7279a46b2707b74bfd92c46d6ca
diff --git a/x11-misc/j4-dmenu-desktop/j4-dmenu-desktop-2.17.ebuild b/x11-misc/j4-dmenu-desktop/j4-dmenu-desktop-2.17-r1.ebuild
index d95530d4b3ed..8a8d8c7525b9 100644
--- a/x11-misc/j4-dmenu-desktop/j4-dmenu-desktop-2.17.ebuild
+++ b/x11-misc/j4-dmenu-desktop/j4-dmenu-desktop-2.17-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit cmake-utils
+inherit cmake
MY_PV="r${PV}"
@@ -14,16 +14,16 @@ SRC_URI="https://github.com/enkore/${PN}/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE="test"
+IUSE="+dmenu test"
RESTRICT="!test? ( test )"
DEPEND="test? ( dev-cpp/catch:1 )"
-RDEPEND="x11-misc/dmenu"
+RDEPEND="dmenu? ( x11-misc/dmenu )"
S="${WORKDIR}/${PN}-${MY_PV}"
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
# Respect users CFLAGS
sed -i -e "s/-pedantic -O2//" CMakeLists.txt || die
@@ -32,14 +32,25 @@ src_prepare() {
src_configure() {
local mycmakeargs=(
-DWITH_GIT_CATCH="no"
- -DWITH_TESTS=$(usex test)
+ -DWITH_TESTS="$(usex test)"
)
- cmake-utils_src_configure
+ cmake_src_configure
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
doman j4-dmenu-desktop.1
}
+
+pkg_postinst() {
+ if ! use dmenu; then
+ elog "As you have disabled the 'dmenu' use flag,"
+ elog "x11-misc/dmenu won't be installed by default."
+ elog ""
+ elog "Since x11-misc/j4-dmenu-desktop uses x11-misc/dmenu as default,"
+ elog "you must configure your own replacement with --dmenu=<command>,"
+ elog "as otherwise it won't work."
+ fi
+}
diff --git a/x11-misc/j4-dmenu-desktop/metadata.xml b/x11-misc/j4-dmenu-desktop/metadata.xml
index 4e3a92938dfe..fd4200a47052 100644
--- a/x11-misc/j4-dmenu-desktop/metadata.xml
+++ b/x11-misc/j4-dmenu-desktop/metadata.xml
@@ -10,6 +10,9 @@
The purpose is to find .desktop files,
but shell commands can also be executed.
</longdescription>
+ <use>
+ <flag name="dmenu">Use <pkg>x11-misc/dmenu</pkg> as default. Disable to use a different implementation.</flag>
+ </use>
<upstream>
<bugs-to>https://github.com/enkore/j4-dmenu-desktop/issues</bugs-to>
<remote-id type="github">enkore/j4-dmenu-desktop</remote-id>