summaryrefslogtreecommitdiff
path: root/x11-misc/i3status/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-misc/i3status/files
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-misc/i3status/files')
-rw-r--r--x11-misc/i3status/files/i3status-2.11-pulseaudio.patch42
1 files changed, 42 insertions, 0 deletions
diff --git a/x11-misc/i3status/files/i3status-2.11-pulseaudio.patch b/x11-misc/i3status/files/i3status-2.11-pulseaudio.patch
new file mode 100644
index 000000000000..2447f16f9339
--- /dev/null
+++ b/x11-misc/i3status/files/i3status-2.11-pulseaudio.patch
@@ -0,0 +1,42 @@
+diff --git a/Makefile b/Makefile
+index 3084ae7..7ea1964 100644
+--- a/Makefile
++++ b/Makefile
+@@ -58,6 +57,10 @@ ifeq ($(OS),NetBSD)
+ LIBS+=-lprop
+ endif
+
++ifeq ($(OS),OpenBSD)
++LIBS+=-lpthread
++endif
++
+ # This probably applies for any pkgsrc based system
+ ifneq (, $(filter $(OS), NetBSD DragonFly))
+ CFLAGS+=-I/usr/pkg/include/
+@@ -79,9 +82,12 @@ CFLAGS += -idirafter yajl-fallback
+ OBJS:=$(sort $(wildcard src/*.c *.c))
+ OBJS:=$(OBJS:.c=.o)
+
+-ifeq ($(OS),OpenBSD)
++PULSE ?= 1
++ifeq ($(PULSE),0)
+ OBJS:=$(filter-out src/pulse.o, $(OBJS))
+ LIBS:=$(filter-out -lpulse, $(LIBS))
++else
++CPPFLAGS+=-DPULSE
+ endif
+
+ src/%.o: src/%.c include/i3status.h
+diff --git a/src/print_volume.c b/src/print_volume.c
+index 51e84f3..9e015c0 100644
+--- a/src/print_volume.c
++++ b/src/print_volume.c
+@@ -61,7 +61,7 @@ void print_volume(yajl_gen json_gen, char *buffer, const char *fmt, const char *
+ free(instance);
+ }
+
+-#ifndef __OpenBSD__
++#if !defined(__OpenBSD__) && defined(PULSE)
+ /* Try PulseAudio first */
+
+ /* If the device name has the format "pulse[:N]" where N is the